aboutsummaryrefslogtreecommitdiffstats
path: root/net/liferea/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2005-05-25 08:43:06 +0800
committerperky <perky@FreeBSD.org>2005-05-25 08:43:06 +0800
commit3d3be8f509e4b2d70e3656d560858a87acdb4551 (patch)
tree73c5fbbcc6a27095b182c5631e04e55b98bac8b9 /net/liferea/Makefile
parentb8389bc9b08d9117cb0a8113cde3e43cd5a8def8 (diff)
downloadfreebsd-ports-gnome-3d3be8f509e4b2d70e3656d560858a87acdb4551.tar.gz
freebsd-ports-gnome-3d3be8f509e4b2d70e3656d560858a87acdb4551.tar.zst
freebsd-ports-gnome-3d3be8f509e4b2d70e3656d560858a87acdb4551.zip
- Allow to build with optional DBUS support.
- Fix a problem on mozilla support that can't find correct MOZILLA_HOME. Submitted by: Andreas Kohn <andreas@syndrom23.de>
Diffstat (limited to 'net/liferea/Makefile')
-rw-r--r--net/liferea/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 0170ace7d727..60ebd697e477 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liferea
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -21,11 +22,14 @@ USE_REINPLACE= yes
USE_LIBTOOL_VER=15
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+=${MOZILLA_ARG} --disable-dbus
MAN1= liferea.1
GCONF_SCHEMAS= liferea.schemas
+OPTIONS= DBUS "Enable dbus support" on
+
+.include <bsd.port.pre.mk>
+
.ifdef WITH_MOZILLA
.if ${WITH_MOZILLA}=="mozilla" || ${WITH_MOZILLA}=="yes"
MOZILLA= mozilla
@@ -33,6 +37,7 @@ MOZ_BUILD= mozilla
.elif ${WITH_MOZILLA}=="mozilla-devel"
MOZILLA= mozilla-devel
MOZ_BUILD= mozilla
+MOZ_SUFFIX= -devel
.elif ${WITH_MOZILLA}=="firefox"
MOZILLA= firefox
MOZ_BUILD= firefox
@@ -49,11 +54,20 @@ PLIST_SUB= MOZ=""
PLIST_SUB= MOZ="@comment "
.endif
+.ifdef WITHOUT_DBUS
+CONFIGURE_ARGS+=--disable-dbus
+.else
+LIB_DEPENDS+= dbus-1.1:${PORTSDIR}/devel/dbus
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's,/usr/lib/mozilla,${X11BASE}/lib/${MOZ_BUILD},g' \
${WRKSRC}/src/liferea
${REINPLACE_CMD} -e 's,firefox-,$$gecko_provider-,g' \
-e 's,\(gecko_provider=\).*$$,\1${MOZ_BUILD},' \
+ -e 's,-gtkmozembed,-gtkmozembed${MOZ_SUFFIX},' \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,%FREEBSD_MOZILLA_HOME%,${X11BASE}/lib/${MOZILLA},' \
+ ${WRKSRC}/src/liferea
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>