aboutsummaryrefslogtreecommitdiffstats
path: root/net/liferea/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-09 04:02:48 +0800
committerpav <pav@FreeBSD.org>2006-05-09 04:02:48 +0800
commit6b258f98dce5ab5c66b872295b3be5e21e09d8cb (patch)
tree5bc29ab710f4f36600121459bfefab9b54bd3539 /net/liferea/Makefile
parent19a07a7e9133aeda063824699ac3bf04e708a39c (diff)
downloadfreebsd-ports-gnome-6b258f98dce5ab5c66b872295b3be5e21e09d8cb.tar.gz
freebsd-ports-gnome-6b258f98dce5ab5c66b872295b3be5e21e09d8cb.tar.zst
freebsd-ports-gnome-6b258f98dce5ab5c66b872295b3be5e21e09d8cb.zip
- Update to 1.0.12
- Get rid of the start wrapper script, we don't need it and it gives up only troubles - Provide an option to install Firefox extension, which can subscribe feeds in Liferea from the orange button in Firefox's address bar - Provide an option to build new Xulrunner plugin
Diffstat (limited to 'net/liferea/Makefile')
-rw-r--r--net/liferea/Makefile37
1 files changed, 34 insertions, 3 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 98f361dbdad5..b063ae45885f 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liferea
-PORTVERSION= 1.0.11
+PORTVERSION= 1.0.12
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -26,7 +26,9 @@ MAN1= liferea.1
GCONF_SCHEMAS= liferea.schemas
OPTIONS= DBUS "Enable dbus support" on \
- MOZILLA "Use Mozilla for rendering" off
+ XPI "Firefox extension to subscribe feeds (req. dbus)" off \
+ MOZILLA "Use Mozilla for rendering" off \
+ XULRUNNER "Use Xulrunner for rendering" off
.include <bsd.port.pre.mk>
@@ -39,6 +41,23 @@ CONFIGURE_ARGS+=--disable-gecko
PLIST_SUB= MOZ="@comment "
.endif
+.ifdef WITH_XPI
+PATCH_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
+RUN_DEPENDS+= firefox:${PORTSDIR}/www/firefox
+PLIST_SUB+= XPI=""
+.else
+PLIST_SUB+= XPI="@comment "
+.endif
+
+.ifdef WITH_XULRUNNER
+BUILD_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
+RUN_DEPENDS+= xulrunner:${PORTSDIR}/www/xulrunner
+PLIST_SUB+= XUL=""
+.else
+CONFIGURE_ARGS+=--disable-xulrunner
+PLIST_SUB+= XUL="@comment "
+.endif
+
.ifdef WITHOUT_DBUS
CONFIGURE_ARGS+=--disable-dbus
.else
@@ -55,7 +74,19 @@ post-patch:
-e 's,{print $$1},{print $$2},g' \
${WRKSRC}/configure
${REINPLACE_CMD} -e 's|gtk_moz_embed_set_comp_path(NULL)|gtk_moz_embed_set_comp_path("${X11BASE}/lib/${GECKO}")|' \
- ${WRKSRC}/src/mozilla/mozembed.c
+ ${WRKSRC}/src/mozilla/mozilla.c
+.endif
+.ifdef WITH_XPI
+ @${MKDIR} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}
+ @${UNZIP_CMD} -q -d ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab} ${WRKSRC}/feedbag.xpi
+.endif
+
+post-install:
+.ifdef WITH_XPI
+ ${MKDIR} ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome
+ ${INSTALL_DATA} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome/feedbag.jar ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome
+ ${INSTALL_DATA} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/chrome.manifest ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}
+ ${INSTALL_DATA} ${WRKDIR}/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}/install.rdf ${PREFIX}/lib/firefox/extensions/{79ea0ec1-3fc3-4ade-8220-262d4c4825ab}
.endif
.include <bsd.port.post.mk>