aboutsummaryrefslogtreecommitdiffstats
path: root/net/linphone-base
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /net/linphone-base
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'net/linphone-base')
-rw-r--r--net/linphone-base/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index 879d21617985..9399a804d524 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -25,15 +25,14 @@ USE_GNOME= glib20 gnomehack intlhack pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure oRTP/configure mediastreamer2/configure
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-ipv6 --disable-manual --disable-ewarning \
--disable-strict --disable-video --disable-external-ortp \
--with-osip=${LOCALBASE} --with-gsm=${LOCALBASE}
MAKE_ENV= SUBDIRS="${SUBDIRS}"
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>