aboutsummaryrefslogtreecommitdiffstats
path: root/net/linux-f10-openldap
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-10-06 22:21:37 +0800
committerrene <rene@FreeBSD.org>2013-10-06 22:21:37 +0800
commit0a6b340d9a8ad24f43897f84ade5a8d5a64b950d (patch)
treeb8b071353c36d68fa5d628c68a1ef257a7961314 /net/linux-f10-openldap
parentbc0dc21bb34f8027d734cf54501a4ee645817bdb (diff)
downloadfreebsd-ports-gnome-0a6b340d9a8ad24f43897f84ade5a8d5a64b950d.tar.gz
freebsd-ports-gnome-0a6b340d9a8ad24f43897f84ade5a8d5a64b950d.tar.zst
freebsd-ports-gnome-0a6b340d9a8ad24f43897f84ade5a8d5a64b950d.zip
Add stage support for linux-f10-* ports maintained by emulation@
(category net).
Diffstat (limited to 'net/linux-f10-openldap')
-rw-r--r--net/linux-f10-openldap/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/net/linux-f10-openldap/Makefile b/net/linux-f10-openldap/Makefile
index de69c7236154..714a7e25d82e 100644
--- a/net/linux-f10-openldap/Makefile
+++ b/net/linux-f10-openldap/Makefile
@@ -18,20 +18,17 @@ RPMVERSION= 1.fc10
USE_LDCONFIG= yes
DESCR= ${.CURDIR}/../openldap24-server/pkg-descr
-PLIST_FILES= usr/lib/liblber-2.4.so.2 usr/lib/liblber-2.4.so.2.2.0 usr/lib/libldap-2.4.so.2 usr/lib/libldap-2.4.so.2.2.0 usr/lib/libldap_r-2.4.so.2 usr/lib/libldap_r-2.4.so.2.2.0 etc/openldap
+PLIST_FILES= usr/lib/liblber-2.4.so.2 usr/lib/liblber-2.4.so.2.2.0 usr/lib/libldap-2.4.so.2 usr/lib/libldap-2.4.so.2.2.0 usr/lib/libldap_r-2.4.so.2 usr/lib/libldap_r-2.4.so.2.2.0 etc/openldap usr/share/man/man5/ldap.conf.5.gz usr/share/man/man5/ldif.5.gz
DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= ANNOUNCEMENT CHANGES COPYRIGHT LICENSE README
-MANPREFIX= ${PREFIX}/usr/share
-MAN5= ldap.conf.5 ldif.5
-MANCOMPRESSED= yes
# do not install any openldap configuration directories/files
-NO_STAGE= yes
post-extract:
${RM} -rf ${WRKSRC}/etc
# use a native openldap configuration directories/files
post-install:
- ${LN} -sf ${LOCALBASE}/etc/openldap ${PREFIX}/etc
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ ${LN} -sf ${LOCALBASE}/etc/openldap ${STAGEDIR}${PREFIX}/etc/openldap
.include <bsd.port.mk>