aboutsummaryrefslogtreecommitdiffstats
path: root/net/linux-jigdo
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-06 08:05:43 +0800
committeredwin <edwin@FreeBSD.org>2003-02-06 08:05:43 +0800
commit48115df5d6660b4bf30857e44f4c9eeb3f4e4528 (patch)
tree40abf70ab9ec0179d4d6f3dace98cb9b8e2f290a /net/linux-jigdo
parente82c7047b1fada9480ef0171c184867409eb2999 (diff)
downloadfreebsd-ports-gnome-48115df5d6660b4bf30857e44f4c9eeb3f4e4528.tar.gz
freebsd-ports-gnome-48115df5d6660b4bf30857e44f4c9eeb3f4e4528.tar.zst
freebsd-ports-gnome-48115df5d6660b4bf30857e44f4c9eeb3f4e4528.zip
New port: net/linux-jigdo
This is a port for the jigdo software, the new method of the Debian project to distribute their images. As I have a debian mirror on a FreeBSD machine I needed that to generate the debian 3.0 iso images here. The sources of jigdo are available but do not work out of the box, so I decided to go with the static binaries in linux-emulation. PR: ports/40834 Submitted by: Udo Schweigert <udo.schweigert@siemens.com>
Diffstat (limited to 'net/linux-jigdo')
-rw-r--r--net/linux-jigdo/Makefile46
-rw-r--r--net/linux-jigdo/distinfo1
-rw-r--r--net/linux-jigdo/pkg-comment1
-rw-r--r--net/linux-jigdo/pkg-descr12
-rw-r--r--net/linux-jigdo/pkg-plist4
5 files changed, 64 insertions, 0 deletions
diff --git a/net/linux-jigdo/Makefile b/net/linux-jigdo/Makefile
new file mode 100644
index 000000000000..cd665d6fa1d7
--- /dev/null
+++ b/net/linux-jigdo/Makefile
@@ -0,0 +1,46 @@
+# ex:ts=8
+# Ports collection makefile for: linux-jigdo
+# Date created: 21 July 2002
+# Whom: Udo Schweigert
+#
+# $FreeBSD$
+#
+
+PORTNAME= jigdo
+PORTVERSION= 0.6.8
+#PORTREVISION?= 0
+CATEGORIES= net
+MASTER_SITES= http://home.in.tum.de/~atterer/jigdo/
+PKGNAMEPREFIX= linux-
+DISTNAME= jigdo-bin-${PORTVERSION}
+
+MAINTAINER= udo.schweigert@siemens.com
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+ONLY_FOR_ARCHS= i386
+USE_BZIP2= YES
+USE_LINUX= yes
+NO_BUILD= yes
+STRIP=
+
+PROGRAMS= jigdo-file
+SCRIPTS= jigdo-lite jigdo-mirror
+
+MAN1= jigdo-file.1 jigdo-lite.1 jigdo-mirror.1
+
+pre-install:
+ @brandelf -t Linux ${WRKSRC}/jigdo-file
+
+do-install:
+.for i in ${PROGRAMS}
+ @${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
+.endfor
+.for i in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/bin
+.endfor
+.for i in ${PROGRAMS} ${SCRIPTS}
+ @${INSTALL_MAN} ${WRKSRC}/$i.1 ${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/linux-jigdo/distinfo b/net/linux-jigdo/distinfo
new file mode 100644
index 000000000000..29948fbd5fa6
--- /dev/null
+++ b/net/linux-jigdo/distinfo
@@ -0,0 +1 @@
+MD5 (jigdo-bin-0.6.8.tar.bz2) = 633d2f6371097256f12e264ac9c6952f
diff --git a/net/linux-jigdo/pkg-comment b/net/linux-jigdo/pkg-comment
new file mode 100644
index 000000000000..95400e81acd4
--- /dev/null
+++ b/net/linux-jigdo/pkg-comment
@@ -0,0 +1 @@
+A tool designed to ease the distribution of very large files
diff --git a/net/linux-jigdo/pkg-descr b/net/linux-jigdo/pkg-descr
new file mode 100644
index 000000000000..8ed8a854201a
--- /dev/null
+++ b/net/linux-jigdo/pkg-descr
@@ -0,0 +1,12 @@
+Jigsaw Download, or short jigdo, is a tool designed to ease the distribution
+of very large files over the internet, for example CD or DVD images. Its aim
+is to make downloading the images as easy for users as a click on a direct
+download link in a browser, while avoiding all the problems that server
+administrators have with hosting such large files.
+
+At the moment this port is only tested to work for building the iso images
+of the Debian GNU/Linux distribution.
+
+WWW: http://home.in.tum.de/~atterer/jigdo/
+
+ -- Udo (udo.schweigert@siemens.com)
diff --git a/net/linux-jigdo/pkg-plist b/net/linux-jigdo/pkg-plist
new file mode 100644
index 000000000000..9dd813138aae
--- /dev/null
+++ b/net/linux-jigdo/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/jigdo-file
+bin/jigdo-lite
+bin/jigdo-mirror