aboutsummaryrefslogtreecommitdiffstats
path: root/net/liveMedia
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2009-02-27 00:35:26 +0800
committernork <nork@FreeBSD.org>2009-02-27 00:35:26 +0800
commit6811221a9be3216a276b60c9c1bb8a87f008e0a1 (patch)
tree81b7f7112a7e2900d7895212b54d0d864539a1b0 /net/liveMedia
parent04c3d1c51ef1f9c8d71311a81f0782056d0a077c (diff)
downloadfreebsd-ports-gnome-6811221a9be3216a276b60c9c1bb8a87f008e0a1.tar.gz
freebsd-ports-gnome-6811221a9be3216a276b60c9c1bb8a87f008e0a1.tar.zst
freebsd-ports-gnome-6811221a9be3216a276b60c9c1bb8a87f008e0a1.zip
o Update to 2009.02.23.
o Change handling -fpic/-fPIC option, radically. [NOTE] I don't know what CFLAGS+=-fpic(-fPIC) doesn't inherit to liveMedia's Makefile, yet. But many people reported this issue. So I don't believe to inherit CFLAGS, and I directly replace CFLAGS in liveMedia's Makefile by sed(1). Related PR: ports/129156, ports/131299 [1] Pointed out by: many people
Diffstat (limited to 'net/liveMedia')
-rw-r--r--net/liveMedia/Makefile5
-rw-r--r--net/liveMedia/distinfo6
-rw-r--r--net/liveMedia/files/config.fixed-freebsd2
3 files changed, 7 insertions, 6 deletions
diff --git a/net/liveMedia/Makefile b/net/liveMedia/Makefile
index 4e11e52e4666..6f1f6446af18 100644
--- a/net/liveMedia/Makefile
+++ b/net/liveMedia/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liveMedia
-PORTVERSION= 2009.01.26
+PORTVERSION= 2009.02.23
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= net devel
@@ -184,7 +184,8 @@ BROKEN= Does not compile
.endif
post-extract:
- @${CP} ${FILESDIR}/config.fixed-${OPSYS:L} ${WRKSRC}/
+ @${SED} -e "s|%%CFLAGS%%|${CFLAGS}|" \
+ ${FILESDIR}/config.fixed-${OPSYS:L} > ${WRKSRC}/config.fixed-${OPSYS:L}
post-build:
@${RM} -f ${PLIST}
diff --git a/net/liveMedia/distinfo b/net/liveMedia/distinfo
index 9d9e5c313037..48666134ca2c 100644
--- a/net/liveMedia/distinfo
+++ b/net/liveMedia/distinfo
@@ -1,3 +1,3 @@
-MD5 (live.2009.01.26.tar.gz) = 7c228d315e8bbe1ec2bd5e1e1b62314b
-SHA256 (live.2009.01.26.tar.gz) = 943dcc39c4991b3d96aa50b7f0ab12ca0a6f33e1664a3c2e5e8cb953e8f6cc0d
-SIZE (live.2009.01.26.tar.gz) = 445292
+MD5 (live.2009.02.23.tar.gz) = 33d99d056ca3b2ca55b38e439be39c0d
+SHA256 (live.2009.02.23.tar.gz) = cf4168494eef4f58c4d37d2bc87944fa1859b0f768c7c5c8a86c069c3b4e91f3
+SIZE (live.2009.02.23.tar.gz) = 445825
diff --git a/net/liveMedia/files/config.fixed-freebsd b/net/liveMedia/files/config.fixed-freebsd
index 55a4a126ad2b..7dfd86ea4116 100644
--- a/net/liveMedia/files/config.fixed-freebsd
+++ b/net/liveMedia/files/config.fixed-freebsd
@@ -1,4 +1,4 @@
-COMPILE_OPTS = $(CFLAGS) $(INCLUDES) -I. -DBSD=1 -DSOCKLEN_T=socklen_t -DHAVE_SOCKADDR_LEN=1
+COMPILE_OPTS = %%CFLAGS%% $(INCLUDES) -I. -DBSD=1 -DSOCKLEN_T=socklen_t -DHAVE_SOCKADDR_LEN=1
C = c
C_COMPILER = $(CC)
C_FLAGS = $(COMPILE_OPTS)