aboutsummaryrefslogtreecommitdiffstats
path: root/net/luasocket/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-06-22 01:12:32 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-06-22 01:12:32 +0800
commit894211f0f5d473c95a395db3a32bbfc6f9ee4c55 (patch)
treed8846e3069d72145a05c35a02d35d91ce98573ad /net/luasocket/Makefile
parent5aa899075677634f93cfaa7744b6c5d0bfdf0cfd (diff)
downloadfreebsd-ports-gnome-894211f0f5d473c95a395db3a32bbfc6f9ee4c55.tar.gz
freebsd-ports-gnome-894211f0f5d473c95a395db3a32bbfc6f9ee4c55.tar.zst
freebsd-ports-gnome-894211f0f5d473c95a395db3a32bbfc6f9ee4c55.zip
- Allow build with lua52 and lua53
- Space/tab fix PR: 200407 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 4 weeks)
Diffstat (limited to 'net/luasocket/Makefile')
-rw-r--r--net/luasocket/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/luasocket/Makefile b/net/luasocket/Makefile
index bf4acee26184..2a3a451d92e6 100644
--- a/net/luasocket/Makefile
+++ b/net/luasocket/Makefile
@@ -15,10 +15,11 @@ USE_GITHUB= yes
GH_ACCOUNT= diegonehab
GH_TAGNAME= v3.0-rc1
-USES= lua:51 gmake pkgconfig
+MAKE_ARGS= LUA_VER=${LUA_VER}
+USES= lua gmake pkgconfig
-CFLAGS+= `pkgconf --cflags lua-${LUA_VER}`
-LDFLAGS+= -shared `pkgconf --libs lua-${LUA_VER}`
+CFLAGS+= `pkgconf --cflags lua-${LUA_VER}`
+LDFLAGS+= -shared `pkgconf --libs lua-${LUA_VER}`
OPTIONS_DEFINE= DOCS