aboutsummaryrefslogtreecommitdiffstats
path: root/net/mad_fcl/files
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-16 20:49:37 +0800
committerkrion <krion@FreeBSD.org>2004-02-16 20:49:37 +0800
commit91b2ae3438295574fbfa673dabc52156f2f6f1a7 (patch)
tree0726471ff7cc387380d2a6e3ec768c97ba34c931 /net/mad_fcl/files
parent5c1e00c4fd27e49758eceb485977196660c697f8 (diff)
downloadfreebsd-ports-gnome-91b2ae3438295574fbfa673dabc52156f2f6f1a7.tar.gz
freebsd-ports-gnome-91b2ae3438295574fbfa673dabc52156f2f6f1a7.tar.zst
freebsd-ports-gnome-91b2ae3438295574fbfa673dabc52156f2f6f1a7.zip
Add mad_fcl 0.5,
MAD/Flute reliable unicast/multicast sending/receiving tool version 0.5. It is an implementation of the RFC3450 Asynchronous Layered Coding (ALC). PR: ports/62688 Submitted by: Janos.Mohacsi@bsd.hu
Diffstat (limited to 'net/mad_fcl/files')
-rw-r--r--net/mad_fcl/files/patch-Makefile27
-rw-r--r--net/mad_fcl/files/patch-alclib::Makefile11
-rw-r--r--net/mad_fcl/files/patch-alclib::fec.c22
-rw-r--r--net/mad_fcl/files/patch-flute::Makefile17
-rw-r--r--net/mad_fcl/files/patch-flute::fdt.c28
-rw-r--r--net/mad_fcl/files/patch-sdplib::Makefile10
-rw-r--r--net/mad_fcl/files/patch-sdplib::port_misc.c20
7 files changed, 135 insertions, 0 deletions
diff --git a/net/mad_fcl/files/patch-Makefile b/net/mad_fcl/files/patch-Makefile
new file mode 100644
index 000000000000..8a84c913c998
--- /dev/null
+++ b/net/mad_fcl/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig Fri Feb 13 15:58:54 2004
++++ Makefile Fri Feb 13 15:58:54 2004
+@@ -4,21 +4,21 @@
+ @echo "-------------------"
+ @echo "*** ALC library ***"
+ @echo "-------------------"
+- mkdir lib; cd alclib; make clean; make
++ mkdir lib; cd alclib; gmake clean; gmake
+ @echo "done"
+
+ sdplib ::
+ @echo "-------------------"
+ @echo "*** SDP library ***"
+ @echo "-------------------"
+- mkdir lib; cd sdplib; make clean; make
++ mkdir lib; cd sdplib; gmake clean; gmake
+ @echo "done"
+
+ flute ::
+ @echo "-------------------------"
+ @echo "*** flute application ***"
+ @echo "-------------------------"
+- mkdir bin; cd flute; make clean; make
++ mkdir bin; cd flute; gmake clean; gmake
+ @echo "done"
+
+ clean :
diff --git a/net/mad_fcl/files/patch-alclib::Makefile b/net/mad_fcl/files/patch-alclib::Makefile
new file mode 100644
index 000000000000..33aa0ffc6833
--- /dev/null
+++ b/net/mad_fcl/files/patch-alclib::Makefile
@@ -0,0 +1,11 @@
+--- alclib/Makefile.orig Fri Feb 13 15:58:54 2004
++++ alclib/Makefile Fri Feb 13 15:58:54 2004
+@@ -1,7 +1,7 @@
+ #CC = ccmalloc gcc-2.95
+ #CC = g++
+ CC = gcc
+-CFLAGS += -Wall -g -fPIC -DLINUX
++CFLAGS += -Wall -g -fPIC -O -DLINUX
+
+ SOURCES = alc_channel.c alc_hdr.c alc_rx.c alc_session.c alc_socket.c alc_tx.c \
+ lct_hdr.c mad.c mad_cc.c transport.c blocking_alg.c fec.c null_fec.c rs_fec.c
diff --git a/net/mad_fcl/files/patch-alclib::fec.c b/net/mad_fcl/files/patch-alclib::fec.c
new file mode 100644
index 000000000000..b1a234046f6b
--- /dev/null
+++ b/net/mad_fcl/files/patch-alclib::fec.c
@@ -0,0 +1,22 @@
+--- alclib/fec.c.orig Fri Feb 13 15:58:54 2004
++++ alclib/fec.c Fri Feb 13 15:58:54 2004
+@@ -268,8 +268,7 @@
+ return p ;
+ }
+
+-#define NEW_GF_MATRIX(rows, cols) \
+- (gf *)my_malloc(rows * cols * sizeof(gf), " ## __LINE__ ## " )
++#define NEW_GF_MATRIX(rows, cols) (gf *)my_malloc(rows * cols * sizeof(gf), " ## __LINE__ ## " )
+
+ /*
+ * initialize the data structures used for computations in GF.
+@@ -350,8 +349,7 @@
+ *
+ * Note that gcc on
+ */
+-#define addmul(dst, src, c, sz) \
+- if (c != 0) addmul1(dst, src, c, sz)
++#define addmul(dst, src, c, sz) if (c != 0) addmul1(dst, src, c, sz)
+
+ #define UNROLL 16 /* 1, 4, 8, 16 */
+ static void
diff --git a/net/mad_fcl/files/patch-flute::Makefile b/net/mad_fcl/files/patch-flute::Makefile
new file mode 100644
index 000000000000..8a7e8401f0fd
--- /dev/null
+++ b/net/mad_fcl/files/patch-flute::Makefile
@@ -0,0 +1,17 @@
+--- flute/Makefile.orig Fri Feb 13 15:58:54 2004
++++ flute/Makefile Fri Feb 13 15:58:54 2004
+@@ -1,10 +1,10 @@
+ #CC = ccmalloc gcc-2.95
+ #CC = g++
+ CC = gcc
+-CFLAGS += -Wall -g -I/usr/local/expat-1.95.6/lib/ -I/usr/local/ssl/include/ -I/usr/java/j2sdk1.4.2/include/ \
+- -I/usr/java/j2sdk1.4.2/include/linux/ -DLINUX -D__VXWORKS_OS__
+-LFLAGS += -DLINUX -D__VXWORKS_OS__ -L../lib -L/usr/local/expat-1.95.6/.libs/ -L/usr/local/ssl/lib/ \
+- -lalc -lsdp -lexpat -lpthread -lm -lssl -lcrypto #-lmpatrol -lelf
++CFLAGS += -Wall -g -O -I/usr/local/include/ \
++ -DLINUX -D__VXWORKS_OS__
++LFLAGS += -DLINUX -pthread -L../lib -L/usr/local/lib \
++ -lalc -lsdp -lexpat -lm -lssl -lcrypto #-lmpatrol -lelf
+
+ SOURCES = main.c flute.c sender.c receiver.c fdt.c fdt_gen.c mad_md5.c uri.c getdnsname.c
+
diff --git a/net/mad_fcl/files/patch-flute::fdt.c b/net/mad_fcl/files/patch-flute::fdt.c
new file mode 100644
index 000000000000..0afb684621d1
--- /dev/null
+++ b/net/mad_fcl/files/patch-flute::fdt.c
@@ -0,0 +1,28 @@
+--- flute/fdt.c.orig Fri Feb 13 15:58:54 2004
++++ flute/fdt.c Fri Feb 13 15:58:54 2004
+@@ -113,14 +113,14 @@
+ #ifdef WIN32
+ file->file_len = _atoi64(*(++atts));
+ #else
+- file->file_len = atoll(*(++atts));
++ file->file_len = strtoll(*(++atts), NULL, 10);
+ #endif
+ }
+ else if(!strcmp(*atts, "Transfer-Length")) {
+ #ifdef WIN32
+ file->toi_len = _atoi64(*(++atts));
+ #else
+- file->toi_len = atoll(*(++atts));
++ file->toi_len = strtoll(*(++atts),NULL, 10);
+ #endif
+ }
+ else if(!strcmp(*atts, "Content-Type")) {
+@@ -179,7 +179,7 @@
+ #ifdef WIN32
+ fdt->expires = _atoi64(*(++atts));
+ #else
+- fdt->expires = atoll(*(++atts));
++ fdt->expires = strtoll(*(++atts), NULL, 10);
+ #endif
+ }
+ else if(!strcmp(*atts, "Complete")) {
diff --git a/net/mad_fcl/files/patch-sdplib::Makefile b/net/mad_fcl/files/patch-sdplib::Makefile
new file mode 100644
index 000000000000..c1ddb7cd497b
--- /dev/null
+++ b/net/mad_fcl/files/patch-sdplib::Makefile
@@ -0,0 +1,10 @@
+--- sdplib/Makefile.orig Fri Feb 13 15:58:54 2004
++++ sdplib/Makefile Fri Feb 13 15:58:54 2004
+@@ -1,6 +1,6 @@
+ #CC = ccmalloc gcc-2.95
+ CC = gcc
+-CFLAGS += -Wall -g -fPIC -DLINUX -D__VXWORKS_OS__
++CFLAGS += -Wall -g -fPIC -DLINUX -O -D__VXWORKS_OS__
+
+ SOURCES = port_list.c port_misc.c sdp_accessor.c sdp_rfc2327.c sdplib.c
+
diff --git a/net/mad_fcl/files/patch-sdplib::port_misc.c b/net/mad_fcl/files/patch-sdplib::port_misc.c
new file mode 100644
index 000000000000..f97f8e8cad18
--- /dev/null
+++ b/net/mad_fcl/files/patch-sdplib::port_misc.c
@@ -0,0 +1,20 @@
+--- sdplib/port_misc.c.orig Fri Feb 13 15:58:54 2004
++++ sdplib/port_misc.c Fri Feb 13 15:58:54 2004
+@@ -47,6 +47,7 @@
+ # include <sys/unistd.h>
+ #endif
+
++#define HAVE_UNISTD_H
+ #if defined (HAVE_UNISTD_H)
+ # include <unistd.h>
+ #endif
+@@ -55,6 +56,9 @@
+ # include <syslog.h>
+ #endif
+
++#include <sys/types.h>
++#include <sys/time.h>
++#define HAVE_SYS_SELECT_H
+ #if defined (HAVE_SYS_SELECT_H)
+ # include <sys/select.h>
+ #endif