aboutsummaryrefslogtreecommitdiffstats
path: root/net/miniupnpd
diff options
context:
space:
mode:
authorjpaetzel <jpaetzel@FreeBSD.org>2010-10-12 22:29:11 +0800
committerjpaetzel <jpaetzel@FreeBSD.org>2010-10-12 22:29:11 +0800
commit119ea9f1d94337a53afe7b40a759c77101f16987 (patch)
tree5059dd35520cc039d25ad6951c2b12c22980bea4 /net/miniupnpd
parent94ef78f0121e5c8e2feb72596309df7224a206f5 (diff)
downloadfreebsd-ports-gnome-119ea9f1d94337a53afe7b40a759c77101f16987.tar.gz
freebsd-ports-gnome-119ea9f1d94337a53afe7b40a759c77101f16987.tar.zst
freebsd-ports-gnome-119ea9f1d94337a53afe7b40a759c77101f16987.zip
Update to latest version.
Add option to enable PF support PR: ports/151394 Submitted by: Eric F Crist <ecrist@secure-computing.net> Approved by: Maintainer (Tor Halvard Furulund <squat@squat.no>) Sponsored by: ClaimLynx, Inc
Diffstat (limited to 'net/miniupnpd')
-rw-r--r--net/miniupnpd/Makefile9
-rw-r--r--net/miniupnpd/distinfo6
-rw-r--r--net/miniupnpd/files/pf_enable_filter_rules.patch11
3 files changed, 22 insertions, 4 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 56c4250b10fe..6ab031cc4bb5 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= miniupnpd
-PORTVERSION= 1.4.20100511
+PORTVERSION= 1.4.20100921
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
http://miniupnp.free.fr/files/
@@ -25,6 +25,13 @@ MAN8= miniupnpd.8
USE_RC_SUBR= miniupnpd.sh
+OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off \
+
+.include <bsd.port.options.mk>
+.if defined(WITH_PF_ENABLE_FILTER_RULES)
+EXTRA_PATCHES= ${PATCHDIR}/pf_enable_filter_rules.patch
+.endif
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${PREFIX}/sbin/miniupnpd
@${INSTALL_DATA} ${WRKDIR}/miniupnpd.conf.sample ${PREFIX}/etc/miniupnpd.conf.sample
diff --git a/net/miniupnpd/distinfo b/net/miniupnpd/distinfo
index cf8a76f4495b..76d7d9902e5a 100644
--- a/net/miniupnpd/distinfo
+++ b/net/miniupnpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (miniupnpd-1.4.20100511.tar.gz) = fa3491d4de8dbfdee55dc7ff7f0b2b3c
-SHA256 (miniupnpd-1.4.20100511.tar.gz) = 1fce907ecaeb49d8a58524c000536a6b6e79789a952e137c9141d50936ea4f0a
-SIZE (miniupnpd-1.4.20100511.tar.gz) = 93281
+MD5 (miniupnpd-1.4.20100921.tar.gz) = 8840fefae59ad3859f9212dcd780d3bf
+SHA256 (miniupnpd-1.4.20100921.tar.gz) = 4f974a123866819c968bcf2162067a59d6b9776bb77d543cc183f3e357084526
+SIZE (miniupnpd-1.4.20100921.tar.gz) = 95483
diff --git a/net/miniupnpd/files/pf_enable_filter_rules.patch b/net/miniupnpd/files/pf_enable_filter_rules.patch
new file mode 100644
index 000000000000..377bdc296b7b
--- /dev/null
+++ b/net/miniupnpd/files/pf_enable_filter_rules.patch
@@ -0,0 +1,11 @@
+--- work/miniupnpd-1.4.20100921/genconfig.sh 2010-09-21 10:36:12.000000000 -0500
++++ genconfig.sh 2010-10-11 10:23:44.000000000 -0500
+@@ -209,7 +209,7 @@
+
+ echo "/* Uncomment the following line to enable generation of" >> ${CONFIGFILE}
+ echo " * filter rules with pf */" >> ${CONFIGFILE}
+-echo "/*#define PF_ENABLE_FILTER_RULES*/">> ${CONFIGFILE}
++echo "#define PF_ENABLE_FILTER_RULES">> ${CONFIGFILE}
+ echo "" >> ${CONFIGFILE}
+
+ echo "/* Uncomment the following line to enable caching of results of" >> ${CONFIGFILE}