aboutsummaryrefslogtreecommitdiffstats
path: root/net/miniupnpd
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-05-12 02:19:38 +0800
committerpawel <pawel@FreeBSD.org>2012-05-12 02:19:38 +0800
commitfbc55f033ae3ebf579ede06033427eb2e2ed1e57 (patch)
treeab46daf511cb908b162a3bfbdddf70bc2c0f3131 /net/miniupnpd
parent6b6ea2905d29af3b17f57f5be12e364b46783e15 (diff)
downloadfreebsd-ports-gnome-fbc55f033ae3ebf579ede06033427eb2e2ed1e57.tar.gz
freebsd-ports-gnome-fbc55f033ae3ebf579ede06033427eb2e2ed1e57.tar.zst
freebsd-ports-gnome-fbc55f033ae3ebf579ede06033427eb2e2ed1e57.zip
- Update to version 1.6 [1]
- Respect global CFLAGS during build - Mark MAKE_JOBS_UNSAFE PR: ports/167770 [1] Submitted by: Tor Halvard Furulund <squat@squat.no> (maintainer) [1]
Diffstat (limited to 'net/miniupnpd')
-rw-r--r--net/miniupnpd/Makefile5
-rw-r--r--net/miniupnpd/distinfo4
-rw-r--r--net/miniupnpd/files/patch-Makefile15
3 files changed, 17 insertions, 7 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 5b7c9d49cece..7298c8d5011a 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= miniupnpd
-PORTVERSION= 1.5
+PORTVERSION= 1.6
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
@@ -21,12 +21,13 @@ SUB_LIST= UUID=${UUID}
UUID!= uuidgen
FWNAME?= pf
PLIST_FILES= etc/miniupnpd.conf.sample sbin/miniupnpd
+MAKE_JOBS_UNSAFE=yes
MAN8= miniupnpd.8
USE_RC_SUBR= miniupnpd.sh
-OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off \
+OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off
.include <bsd.port.options.mk>
.if defined(WITH_PF_ENABLE_FILTER_RULES)
diff --git a/net/miniupnpd/distinfo b/net/miniupnpd/distinfo
index 6205a0ca7278..6cf599be1363 100644
--- a/net/miniupnpd/distinfo
+++ b/net/miniupnpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (miniupnpd-1.5.tar.gz) = 402db10f46d23ffcafbb655ad7333daf1271fb115f92aa293e22cc974fa8da30
-SIZE (miniupnpd-1.5.tar.gz) = 98993
+SHA256 (miniupnpd-1.6.tar.gz) = a26744025038a207d96a2dce96aa76db095886eb68dee87321b9da55cb1c8585
+SIZE (miniupnpd-1.6.tar.gz) = 124917
diff --git a/net/miniupnpd/files/patch-Makefile b/net/miniupnpd/files/patch-Makefile
index ec0841685816..453e3f547ac6 100644
--- a/net/miniupnpd/files/patch-Makefile
+++ b/net/miniupnpd/files/patch-Makefile
@@ -1,6 +1,15 @@
---- Makefile.orig 2009-11-06 08:23:18.000000000 +0800
-+++ Makefile 2009-11-06 08:23:31.000000000 +0800
-@@ -25,10 +25,12 @@
+--- Makefile.orig 2011-05-27 00:49:17.000000000 +0200
++++ Makefile 2012-05-11 19:42:37.000000000 +0200
+@@ -11,7 +11,7 @@
+ # Linux users, please use Makefile.linux :
+ # make -f Makefile.linux
+
+-CFLAGS = -pipe -Wall -Os
++CFLAGS += -pipe -Wall
+ #CFLAGS = -pipe -Wall -O -g -DDEBUG
+ CC ?= gcc
+ RM = rm -f
+@@ -32,10 +32,12 @@
# better way to find if we are using ipf or pf
.if $(OSNAME) == "FreeBSD"