aboutsummaryrefslogtreecommitdiffstats
path: root/net/mmucl/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-09-16 12:21:21 +0800
committerwill <will@FreeBSD.org>2000-09-16 12:21:21 +0800
commit423d389aaa3da7a6fd20868c1d2cbe96994f79fb (patch)
tree9af18209b41881ec8ef9290d6deaa3aea3bd36ef /net/mmucl/Makefile
parent9c0fa894e59bd33034ccda5d55265f4d5871a2de (diff)
downloadfreebsd-ports-gnome-423d389aaa3da7a6fd20868c1d2cbe96994f79fb.tar.gz
freebsd-ports-gnome-423d389aaa3da7a6fd20868c1d2cbe96994f79fb.tar.zst
freebsd-ports-gnome-423d389aaa3da7a6fd20868c1d2cbe96994f79fb.zip
Add mmucl 1.4.0, a powerful MUD client written in Tcl with a GUI interface.
PR: 20238 Submitted by: Matt Heckaman <matt@LUCIDA.QC.CA>
Diffstat (limited to 'net/mmucl/Makefile')
-rw-r--r--net/mmucl/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/mmucl/Makefile b/net/mmucl/Makefile
new file mode 100644
index 000000000000..7bd34177ed3c
--- /dev/null
+++ b/net/mmucl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection Makefile for: mmucl
+# Date created: 28 July 2000
+# Whom: Matt Heckaman <matt@LUCIDA.QC.CA>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mmucl
+PORTVERSION= 1.4.0
+CATEGORIES= net
+MASTER_SITES= http://download.sourceforge.net/mmucl/
+
+MAINTAINER= matt@LUCIDA.QC.CA
+
+LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+
+USE_GMAKE= YES
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/doc/${DISTNAME}
+ ${MKDIR} ${PREFIX}/share/doc/${DISTNAME}/examples
+ ${INSTALL_DATA} ${WRKSRC}/FAQ ${PREFIX}/share/doc/${DISTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${DISTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/${DISTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/doc/${DISTNAME}/examples
+
+.include <bsd.port.mk>