aboutsummaryrefslogtreecommitdiffstats
path: root/net/mpd-l2tp-ipv6pd-client
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2012-06-17 03:48:10 +0800
committerume <ume@FreeBSD.org>2012-06-17 03:48:10 +0800
commitb3b56076b2f2beebc4c9e246471992fe0961928d (patch)
treea12c4260394432bab5a1475a103cef3a913aef5d /net/mpd-l2tp-ipv6pd-client
parentd4202fd56c042fe87f0d2aadc2bc1cc6e532960d (diff)
downloadfreebsd-ports-gnome-b3b56076b2f2beebc4c9e246471992fe0961928d.tar.gz
freebsd-ports-gnome-b3b56076b2f2beebc4c9e246471992fe0961928d.tar.zst
freebsd-ports-gnome-b3b56076b2f2beebc4c9e246471992fe0961928d.zip
Convert to use new OPTIONS framework.
Diffstat (limited to 'net/mpd-l2tp-ipv6pd-client')
-rw-r--r--net/mpd-l2tp-ipv6pd-client/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net/mpd-l2tp-ipv6pd-client/Makefile b/net/mpd-l2tp-ipv6pd-client/Makefile
index e9bcccd3f2e2..f3dfdc6eb4d3 100644
--- a/net/mpd-l2tp-ipv6pd-client/Makefile
+++ b/net/mpd-l2tp-ipv6pd-client/Makefile
@@ -20,16 +20,15 @@ MANUAL_PACKAGE_BUILD=yes
NO_PACKAGE= yes
USE_RC_SUBR= yes
-OPTIONS= MPD4 "Use mpd4" off \
- MPD5 "Use mpd5" on
+OPTIONS_SINGLE= MPD
+OPTIONS_SINGLE_MPD= MPD4 MPD5
+OPTIONS_DEFAULT= MPD5
+MPD4_DESC= Use mpd4
+MPD5_DESC= Use mpd5
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MPD5) && defined(WITH_MPD4)
-BROKEN= Multiple mpd versions selected. Run 'make config' again!
-.endif
-
-.if defined(WITH_MPD4)
+.if ${PORT_OPTIONS:MMPD4}
MPD_NAME= mpd4
MPD4= ""
.else
@@ -82,7 +81,7 @@ do-install:
exit 1; \
fi
@${MKDIR} ${PREFIX}/${CONF_DIR}
-.if defined(WITH_MPD4)
+.if ${PORT_OPTIONS:MMPD4}
@${INSTALL_DATA} ${WRKDIR}/mpd.conf ${PREFIX}/${CONF_DIR}/mpd.conf
@${INSTALL_DATA} ${WRKDIR}/mpd.links ${PREFIX}/${CONF_DIR}/mpd.links
.else
@@ -101,4 +100,4 @@ do-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>