aboutsummaryrefslogtreecommitdiffstats
path: root/net/mpich2
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-12-21 00:39:14 +0800
committerthierry <thierry@FreeBSD.org>2015-12-21 00:39:14 +0800
commit04ad937292ee5819241a65643f51babcd1bc17b8 (patch)
tree72b8dab553c8fe6a79497e7fa59676e91451724f /net/mpich2
parentfc2c88bddd6a6934fcc3eb9baac8d334747d811f (diff)
downloadfreebsd-ports-gnome-04ad937292ee5819241a65643f51babcd1bc17b8.tar.gz
freebsd-ports-gnome-04ad937292ee5819241a65643f51babcd1bc17b8.tar.zst
freebsd-ports-gnome-04ad937292ee5819241a65643f51babcd1bc17b8.zip
USES=execinfo localbase switch.
PR: ports/205388 Submitted by: pawel
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 1a1c804a4272..99876179404b 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -18,11 +18,11 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
-USES= libtool:keepla fortran perl5 pkgconfig python
+USES= execinfo libtool:keepla localbase fortran perl5 \
+ pkgconfig python
USE_GCC= yes
USE_LDCONFIG= yes
USE_PERL5= build
@@ -46,8 +46,6 @@ CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
PACKAGE="${PORTNAME}" \
PTHREAD_LIBS="-lpthread"
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
.if ${FFLAGS} == "-O"
FFLAGS= -O2
.endif