aboutsummaryrefslogtreecommitdiffstats
path: root/net/mtr
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2004-03-30 18:50:03 +0800
committersumikawa <sumikawa@FreeBSD.org>2004-03-30 18:50:03 +0800
commit218696f827e80dc965dbbc1721ec7a9687431d4d (patch)
tree5db9e9abda99c97b6adb14074f1dab3c8c85ce10 /net/mtr
parent24a5c5fc715c005fd9405274096d66fd2e462633 (diff)
downloadfreebsd-ports-gnome-218696f827e80dc965dbbc1721ec7a9687431d4d.tar.gz
freebsd-ports-gnome-218696f827e80dc965dbbc1721ec7a9687431d4d.tar.zst
freebsd-ports-gnome-218696f827e80dc965dbbc1721ec7a9687431d4d.zip
Another fix for -a option. BSD detection logic seems be wrong.
Essential fix is necessary. Approved by: billf
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile2
-rw-r--r--net/mtr/files/patch-0119
2 files changed, 15 insertions, 6 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index a09622e9cfbc..3955640b54f8 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mtr
PORTVERSION= 0.54
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
ftp://ftp.netsw.org/net/ip/audit/packets/ \
diff --git a/net/mtr/files/patch-01 b/net/mtr/files/patch-01
index ca7161240942..651add54d7a8 100644
--- a/net/mtr/files/patch-01
+++ b/net/mtr/files/patch-01
@@ -1,8 +1,17 @@
---- net.c.orig Wed Jun 9 11:06:27 1999
-+++ net.c Wed Jul 14 02:03:23 1999
-@@ -213,7 +213,7 @@
- rv = sendto(sendsock, packet, packetsize, 0,
- (struct sockaddr *)&remoteaddress, sizeof(remoteaddress));
+--- net.c.orig Mon Mar 29 20:18:08 2004
++++ net.c Mon Mar 29 20:18:34 2004
+@@ -178,7 +178,7 @@
+ }
+
+
+-static int BSDfix = 0;
++static int BSDfix = 1;
+
+ int new_sequence(int index) {
+ static int next_sequence = 0;
+@@ -261,7 +261,7 @@
+ #endif
+ );
if (rv >= 0) {
- fprintf (stderr, "You've got a broken (FreeBSD?) system\n");
+/* fprintf (stderr, "You've got a broken (FreeBSD?) system\n"); */