aboutsummaryrefslogtreecommitdiffstats
path: root/net/nakenchat
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-08 13:03:23 +0800
committeredwin <edwin@FreeBSD.org>2003-10-08 13:03:23 +0800
commit16beec40b4ad5c171281643c14f99dd1ad34aa4e (patch)
treeaf44d6d842e46c319c2bd98161bc1ff26509535c /net/nakenchat
parent59130ac9493c6a0401768eb0e8b7e82d0b85837b (diff)
downloadfreebsd-ports-gnome-16beec40b4ad5c171281643c14f99dd1ad34aa4e.tar.gz
freebsd-ports-gnome-16beec40b4ad5c171281643c14f99dd1ad34aa4e.tar.zst
freebsd-ports-gnome-16beec40b4ad5c171281643c14f99dd1ad34aa4e.zip
adding Naken Chat to FreeBSD ports
Small chat server written in C. The compiled code is still under 50k (at this time around 40k). The chat offers many features including private channels, gagging, squelching, banning, censoring, and much more. Users can connect to the chat through many ways including telnet and a Java applet through a webpage. PR: ports/54583 Submitted by: Michael A. Kohn <mike@mikekohn.net> <mikekohn@everyday.com>
Diffstat (limited to 'net/nakenchat')
-rw-r--r--net/nakenchat/Makefile16
-rw-r--r--net/nakenchat/distinfo1
-rw-r--r--net/nakenchat/files/patch-Makefile11
-rw-r--r--net/nakenchat/pkg-descr11
-rw-r--r--net/nakenchat/pkg-plist3
5 files changed, 42 insertions, 0 deletions
diff --git a/net/nakenchat/Makefile b/net/nakenchat/Makefile
new file mode 100644
index 000000000000..5eb156a34bc8
--- /dev/null
+++ b/net/nakenchat/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: nakenchat
+# Date created: 01 July 2003
+# Whom: Michael Kohn (mike@mikekohn.net)
+#
+# $FreeBSD$
+#
+
+PORTNAME= nakenchat
+PORTVERSION= 2.00
+CATEGORIES= net
+MASTER_SITES= http://www.mikekohn.com/nakenchat/
+
+MAINTAINER= mike@mikekohn.net
+COMMENT= Small (under 50k) chat server with many features
+
+.include <bsd.port.mk>
diff --git a/net/nakenchat/distinfo b/net/nakenchat/distinfo
new file mode 100644
index 000000000000..e77fee8246cb
--- /dev/null
+++ b/net/nakenchat/distinfo
@@ -0,0 +1 @@
+MD5 (nakenchat-2.00.tar.gz) = 054a05c64686cd781b47cffe449db9fd
diff --git a/net/nakenchat/files/patch-Makefile b/net/nakenchat/files/patch-Makefile
new file mode 100644
index 000000000000..55c122221cff
--- /dev/null
+++ b/net/nakenchat/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Tue Oct 7 22:01:27 2003
++++ Makefile Tue Oct 7 22:01:41 2003
+@@ -1,6 +1,6 @@
+
+-CC=gcc
+-BASEDIR=/usr/local
++CC?=gcc
++BASEDIR=${PREFIX}
+
+ all:
+ cd src && make
diff --git a/net/nakenchat/pkg-descr b/net/nakenchat/pkg-descr
new file mode 100644
index 000000000000..4ad20e408490
--- /dev/null
+++ b/net/nakenchat/pkg-descr
@@ -0,0 +1,11 @@
+Small chat server written in C. The compiled code is still under
+50k (at this time around 40k). The chat offers many features
+including private channels, gagging, squelching, banning,
+censoring, and much more. Users can connect to the chat through
+many ways including telnet and a Java applet through a webpage.
+
+WWW: http://nakenchat.naken.cc/
+
+-Michael Kohn
+
+mike@mikekohn.net
diff --git a/net/nakenchat/pkg-plist b/net/nakenchat/pkg-plist
new file mode 100644
index 000000000000..8d2a43446e9d
--- /dev/null
+++ b/net/nakenchat/pkg-plist
@@ -0,0 +1,3 @@
+bin/nakenchat
+bin/nakenpasswd
+etc/nakenchat.conf