aboutsummaryrefslogtreecommitdiffstats
path: root/net/nam/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-08 11:52:06 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-08 11:52:06 +0800
commit3a2337ade1dcff7dc5e2f03d06103e89782f7fc7 (patch)
tree7a28d0c244361c834d2e5f4237325e2e8ddf1746 /net/nam/Makefile
parent5b88468f7e5ce37c99b198353fea0cee76bbf04d (diff)
downloadfreebsd-ports-gnome-3a2337ade1dcff7dc5e2f03d06103e89782f7fc7.tar.gz
freebsd-ports-gnome-3a2337ade1dcff7dc5e2f03d06103e89782f7fc7.tar.zst
freebsd-ports-gnome-3a2337ade1dcff7dc5e2f03d06103e89782f7fc7.zip
1. fix build ; values.h problem
2. reset maintainer ; maintainer timeout 3. utilize PORTDOCS PR: 43607 (1) (2) Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'net/nam/Makefile')
-rw-r--r--net/nam/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/net/nam/Makefile b/net/nam/Makefile
index f3980e58a381..ffb0d03a52f2 100644
--- a/net/nam/Makefile
+++ b/net/nam/Makefile
@@ -9,9 +9,9 @@ PORTNAME= nam
PORTVERSION= 1.0a9
CATEGORIES= net
MASTER_SITES= http://www.isi.edu/nsnam/dist/
-DISTFILES= nam-src-${PORTVERSION}.tar.gz
+DISTNAME= nam-src-${PORTVERSION}
-MAINTAINER= obonilla@fisicc-ufm.edu
+MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
@@ -19,20 +19,21 @@ LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
MAN1= nam.1
MANCOMPRESSED= no
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl-ver=8.3 --with-tk-ver=8.3
-ALL_TARGET=
+ALL_TARGET= # empty
post-patch:
- @${SED} -e 's,friend Queue,friend class Queue,' < ${WRKSRC}/queue.h > \
- ${WRKSRC}/queue.h.new
- @${MV} ${WRKSRC}/queue.h.new ${WRKSRC}/queue.h
+ @${REINPLACE_CMD} -e 's,friend Queue,friend class Queue,' ${WRKSRC}/queue.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nam ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/nam.1 ${PREFIX}/man/man1
- ${MKDIR} ${PREFIX}/share/examples/nam
- ${INSTALL_DATA} ${WRKSRC}/ex/* ${PREFIX}/share/examples/nam
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ex/* ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>