aboutsummaryrefslogtreecommitdiffstats
path: root/net/nast/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-04-28 00:41:53 +0800
committerfjoe <fjoe@FreeBSD.org>2003-04-28 00:41:53 +0800
commita6c5e3ed4aaf331490a1d0f6f8a96a9993cd27e4 (patch)
treeb23f8f47980c5866bf505ce58ef89287c1777d09 /net/nast/Makefile
parent94b55e755e8122574935f84df8a428f307ad6fd7 (diff)
downloadfreebsd-ports-gnome-a6c5e3ed4aaf331490a1d0f6f8a96a9993cd27e4.tar.gz
freebsd-ports-gnome-a6c5e3ed4aaf331490a1d0f6f8a96a9993cd27e4.tar.zst
freebsd-ports-gnome-a6c5e3ed4aaf331490a1d0f6f8a96a9993cd27e4.zip
New port: nast
Nast is a packet sniffer and a LAN analyzer based on Libnet and Libpcap. PR: 51310 Submitted by: Kirill Ponomarew <ponomarew@oberon.net>
Diffstat (limited to 'net/nast/Makefile')
-rw-r--r--net/nast/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net/nast/Makefile b/net/nast/Makefile
new file mode 100644
index 000000000000..579594cc2a36
--- /dev/null
+++ b/net/nast/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: nast
+# Date created: Sun Apr 6 10:12:16 CEST 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nast
+PORTVERSION= 0.1.7d
+CATEGORIES= net
+MASTER_SITES= http://nast.berlios.de/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Nast is a packet sniffer
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+
+MAN8= nast.8
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} ""#######################################################
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You need ${PORTSDIR}/net/libnet-devel to build this port
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} ""#######################################################
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8/
+
+post-install:
+ ${CHMOD} 0755 ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.post.mk>