aboutsummaryrefslogtreecommitdiffstats
path: root/net/ncplib/Makefile
diff options
context:
space:
mode:
authorbp <bp@FreeBSD.org>1999-12-10 19:19:13 +0800
committerbp <bp@FreeBSD.org>1999-12-10 19:19:13 +0800
commitbfa550c19ee3bfa657548f89ff3261866d533954 (patch)
tree47864bdf99c4692ea5c71d4875647f62e25ff56e /net/ncplib/Makefile
parent959834ba9d3067b53c69e3b3c07caec284569e1c (diff)
downloadfreebsd-ports-gnome-bfa550c19ee3bfa657548f89ff3261866d533954.tar.gz
freebsd-ports-gnome-bfa550c19ee3bfa657548f89ff3261866d533954.tar.zst
freebsd-ports-gnome-bfa550c19ee3bfa657548f89ff3261866d533954.zip
Add new port for ncplib - a NetWare client for FreeBSD.
Diffstat (limited to 'net/ncplib/Makefile')
-rw-r--r--net/ncplib/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/ncplib/Makefile b/net/ncplib/Makefile
new file mode 100644
index 000000000000..cbe53fcea764
--- /dev/null
+++ b/net/ncplib/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ncplib
+# Version required: 1.3.4
+# Date created: 9 Dec 1999
+# Whom: Boris Popov <bp@butya.kz>
+#
+# $Id$
+#
+
+DISTNAME= ncplib-1.3.4
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.butya.kz/pub/nwlib/ \
+ http://www.chat.ru/~rbp/pub/nwlib/
+
+MAINTAINER= bp@butya.kz
+
+.if !exists(/usr/src/sys/kern/vnode_if.src)
+BROKEN= requires kernel source
+.endif
+
+NO_PACKAGE= is interactive
+
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 310000
+.error this program requires FreeBSD 3.1-stable or later.
+.endif
+
+MAN1= ncpasswd.1 ncprint.1 ncpsend.1 ncpurge.1
+MAN8= ipxping.8
+
+.if ${OSVERSION} >= 400000
+PLIST= ${PKGDIR}/PLIST.4
+.else
+MAN1+= ncplist.1 ncplogin.1 ncplogout.1
+MAN8+= mount_nwfs.8
+.endif
+
+.include <bsd.port.post.mk>