aboutsummaryrefslogtreecommitdiffstats
path: root/net/netatalk-devel/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-05-19 04:00:30 +0800
committerdinoex <dinoex@FreeBSD.org>2001-05-19 04:00:30 +0800
commiteee67e477fb1836fa47fb15ccccccf890474e8b9 (patch)
tree2511c8dc4c6a43033c3542280283e042901d0461 /net/netatalk-devel/Makefile
parent7da41935f3e2030e84c44da1a92345f33eaaf008 (diff)
downloadfreebsd-ports-gnome-eee67e477fb1836fa47fb15ccccccf890474e8b9.tar.gz
freebsd-ports-gnome-eee67e477fb1836fa47fb15ccccccf890474e8b9.tar.zst
freebsd-ports-gnome-eee67e477fb1836fa47fb15ccccccf890474e8b9.zip
- Update to 1.5pre6
- New MASTER_SITE, see http://netatalk.sourceforge.net/ - This version includes Adrian Sun's improvements - experimental PAM support (disabled by deafult) - package won't override existings configurations - Status script "macusers" - Maintainer: Joe "Marcus" Clarke PR: 26248 Submitted by: jclarke@cisco.com, dirk.meyer@dinoex.sub.org
Diffstat (limited to 'net/netatalk-devel/Makefile')
-rw-r--r--net/netatalk-devel/Makefile65
1 files changed, 47 insertions, 18 deletions
diff --git a/net/netatalk-devel/Makefile b/net/netatalk-devel/Makefile
index d94a7d955260..73afe9262806 100644
--- a/net/netatalk-devel/Makefile
+++ b/net/netatalk-devel/Makefile
@@ -6,31 +6,60 @@
#
PORTNAME= netatalk
-PORTVERSION= 1.4b2
-PORTREVISION= 2
+PORTVERSION= 1.5p6
CATEGORIES= net print
-MASTER_SITES= ftp://terminator.rs.itd.umich.edu/unix/netatalk/ \
- ${MASTER_SITE_LOCAL} \
- ftp://ftp.hanse.de/sites/transit/mirror/terminator.rs.itd.umich.edu/unix/netatalk/
-MASTER_SITE_SUBDIR= stb/mirror/terminator.rs.itd.umich.edu/unix/netatalk
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= netatalk
+DISTNAME= netatalk-1.5pre6
-PATCH_SITES= http://www.umich.edu/~rsug/netatalk/patches/1.4b2/ \
- ${MASTER_SITE_LOCAL} \
- ftp://ftp.hanse.de/sites/transit/mirror/www.umich.edu/%257Ersug/netatalk/patches/1.4b2/
-PATCH_SITE_SUBDIR= stb/mirror/www.umich.edu/%7Ersug/netatalk/patches/1.4b2/
-PATCHFILES= afpd-macos8.diff afpd-bfree.diff
+MAINTAINER= marcus@marcuscom.com
-MAINTAINER= ports@freebsd.org
-
-MAN1= aecho.1 getzones.1 megatron.1 nbp.1 pap.1 psorder.1 hqx2bin.1 \
- macbinary.1 nbplkup.1 nbprgstr.1 nbpunrgstr.1 \
- papstatus.1 single2bin.1 unbin.1 unhex.1 unsingle.1
+.if !exists(/usr/include/tcpd.h)
+LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
+.endif
+CONFIGURE_ARGS+= --with-tcp-wrappers
+# CONFIGURE_ARGS+= --disable-admin-group
+# CONFIGURE_ARGS+= --disable-ddp
+# CONFIGURE_ARGS+= --with-shadow
+# CONFIGURE_ARGS+= --enable-lastdid
+.if defined(NETATALK_WITH_PAM)
+CONFIGURE_ARGS+= --with-pam # broken
+PLIST_SUB+= NETATALKPAM=""
+.else
+PLIST_SUB+= NETATALKPAM="@comment "
+.endif
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+FILES= AppleVolumes.default AppleVolumes.system afpd.conf \
+ atalkd.conf netatalk.conf netatalk.pamd papd.conf
+LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
+ binheader nadheader
+MAN1= aecho.1 afile.1 afppasswd.1 getzones.1 megatron.1 \
+ nbp.1 pap.1 psorder.1 hqx2bin.1 macbinary.1 nbplkup.1 \
+ nbprgstr.1 nbpunrgstr.1 papstatus.1 single2bin.1 \
+ unbin.1 unhex.1 unsingle.1
MAN3= atalk_aton.3 nbp_name.3
MAN4= atalk.4
-MAN8= afpd.8 atalkd.8 papd.8 psf.8
+MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
+ netatalk.conf.5 papd.conf.5
+MAN8= afpd.8 atalkd.8 pap.8 papd.8 papstatus.8 psf.8
+
+post-extract:
+ @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/netatalk.sh \
+ > ${WRKSRC}/netatalk.sh
post-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${RM} -f ${PREFIX}/bin/nu ${PREFIX}/bin/lp2pap
+ ${INSTALL_SCRIPT} ${WRKSRC}/netatalk.sh ${PREFIX}/etc/rc.d/netatalk.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/macusers/macusers \
+ ${PREFIX}/bin/macusers
+.for i in ${FILES}
+ [ -f ${PREFIX}/etc/${i} ] || \
+ ${INSTALL_DATA} -c ${PREFIX}/etc/${i}.dist ${PREFIX}/etc/${i}
+.endfor
+.for i in ${LINKS}
+ ( cd ${PREFIX} && ${LN} -sf megatron ${i} )
+.endfor
.include <bsd.port.mk>