aboutsummaryrefslogtreecommitdiffstats
path: root/net/netatalk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2012-04-29 08:43:37 +0800
committermarcus <marcus@FreeBSD.org>2012-04-29 08:43:37 +0800
commit74437b92206efd75bcb3b185a78b0d775f5f5c85 (patch)
tree8e9ea877a9faabbf72c2effd9d541639b5b2a730 /net/netatalk
parent1b216d176d1715a70cc78b3f35ee6178de09de72 (diff)
downloadfreebsd-ports-gnome-74437b92206efd75bcb3b185a78b0d775f5f5c85.tar.gz
freebsd-ports-gnome-74437b92206efd75bcb3b185a78b0d775f5f5c85.tar.zst
freebsd-ports-gnome-74437b92206efd75bcb3b185a78b0d775f5f5c85.zip
Disable sendfile support by default and make it optional. Sendfile
can cause performance and excessive I/O problems when used with ZFS. PR: 167385 Submitted by: Daniel Becker <razzfazz@gmail.com>
Diffstat (limited to 'net/netatalk')
-rw-r--r--net/netatalk/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index dfbf70c67cbb..57ae6c986f70 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netatalk
PORTVERSION= 2.2.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net print
MASTER_SITES= SF
@@ -39,7 +40,8 @@ OPTIONS= APPLETALK "Enable AppleTalk protocol support" on \
TIMELORD "Enable Timelord network time service" off \
KRB5 "Enable Kerberos V UAM" off \
ZEROCONF "Enable Zeroconf (Bonjour) support" on \
- LDAP "Enable LDAP support" off
+ LDAP "Enable LDAP support" off \
+ SENDFILE "Enable sendfile support" off
FILES= AppleVolumes.default AppleVolumes.system afpd.conf netatalk.conf
LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
@@ -119,6 +121,12 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --without-ldap
.endif
+.if defined (WITH_SENDFILE)
+CONFIGURE_ARGS+= --enable-sendfile
+.else
+CONFIGURE_ARGS+= --disable-sendfile
+.endif
+
.if ${OSVERSION} < 800031
PLIST_SUB+= ATFUNCS="@comment "
.else