aboutsummaryrefslogtreecommitdiffstats
path: root/net/netdude
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-05-14 15:42:58 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-05-14 15:42:58 +0800
commit7c0f975b696445b7458e49c45e8e9286b41c3939 (patch)
tree61cde3191bc2e87af7e6f8a19e5632c0bef67af8 /net/netdude
parent99c025a53955bc4bda66ee33f9816ad19d096385 (diff)
downloadfreebsd-ports-gnome-7c0f975b696445b7458e49c45e8e9286b41c3939.tar.gz
freebsd-ports-gnome-7c0f975b696445b7458e49c45e8e9286b41c3939.tar.zst
freebsd-ports-gnome-7c0f975b696445b7458e49c45e8e9286b41c3939.zip
Submitted by: Patrick MARIE <mycroft@virgaria.org>
Unbreak netdude in -current and bump PORTREVISION.
Diffstat (limited to 'net/netdude')
-rw-r--r--net/netdude/Makefile9
-rw-r--r--net/netdude/files/patch-protocols-fddi::nd_fddi_callbacks.c4
-rw-r--r--net/netdude/files/protocols-fddi::nd_fddi.h.patch11
3 files changed, 21 insertions, 3 deletions
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index 94e7426a4112..e2a6afb4a1ba 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -8,6 +8,7 @@
PORTNAME= netdude
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,6 +30,12 @@ INSTALL_SHLIB= yes
MAN1= netdude.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+EXTRA_PATCHES= ${FILESDIR}/protocols-fddi::nd_fddi.h.patch
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|gtk-config|${GTK_CONFIG}|g" \
-e "s|glib-config|${GLIB_CONFIG}|g" ${WRKSRC}/configure
@@ -43,4 +50,4 @@ post-patch:
-e "s|->un.echo.sequence|->icmp_seq|g" \
${WRKSRC}/protocols/icmp/nd_icmp.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/netdude/files/patch-protocols-fddi::nd_fddi_callbacks.c b/net/netdude/files/patch-protocols-fddi::nd_fddi_callbacks.c
index deccca6b52cb..a54de196327f 100644
--- a/net/netdude/files/patch-protocols-fddi::nd_fddi_callbacks.c
+++ b/net/netdude/files/patch-protocols-fddi::nd_fddi_callbacks.c
@@ -1,11 +1,11 @@
--- protocols/fddi/nd_fddi_callbacks.c.orig Wed Nov 20 21:37:07 2002
+++ protocols/fddi/nd_fddi_callbacks.c Wed Nov 20 21:38:04 2002
-@@ -22,7 +22,9 @@
+@@ -22,7 +22,8 @@
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
*/
+#include <sys/types.h>
- #include <netinet/if_fddi.h>
+-#include <netinet/if_fddi.h>
+#define FDDI_K_ALEN 6
#include <netdude/nd_debug.h>
diff --git a/net/netdude/files/protocols-fddi::nd_fddi.h.patch b/net/netdude/files/protocols-fddi::nd_fddi.h.patch
new file mode 100644
index 000000000000..33915ad993cc
--- /dev/null
+++ b/net/netdude/files/protocols-fddi::nd_fddi.h.patch
@@ -0,0 +1,11 @@
+--- protocols/fddi/nd_fddi.h.orig Tue May 13 10:34:37 2003
++++ protocols/fddi/nd_fddi.h Tue May 13 10:40:53 2003
+@@ -26,7 +26,7 @@
+ #ifndef __nd_fddi_h
+ #define __nd_fddi_h
+
+-#include <netinet/if_fddi.h>
++#include <net/fddi.h>
+
+ #include <netdude/nd_gettext.h>
+ #include <netdude/nd_packet.h>