aboutsummaryrefslogtreecommitdiffstats
path: root/net/netsaint
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2002-06-11 16:13:54 +0800
committerkuriyama <kuriyama@FreeBSD.org>2002-06-11 16:13:54 +0800
commit2b6be58a74cf5cf6b9d8e3fd7c1d315dd21a0e5f (patch)
tree22b3742606776c64e62f23a81b6e60e5b43999ec /net/netsaint
parentc8ecd385c842da861ab58fdf53f8317703733927 (diff)
downloadfreebsd-ports-gnome-2b6be58a74cf5cf6b9d8e3fd7c1d315dd21a0e5f.tar.gz
freebsd-ports-gnome-2b6be58a74cf5cf6b9d8e3fd7c1d315dd21a0e5f.tar.zst
freebsd-ports-gnome-2b6be58a74cf5cf6b9d8e3fd7c1d315dd21a0e5f.zip
Fix about check_by_ssh plugin and fcntl().
PR: ports/31352, ports/39018 Submitted by: Stanley.Hopcroft@IPAustralia.Gov.AU (via maintainer)
Diffstat (limited to 'net/netsaint')
-rw-r--r--net/netsaint/Makefile1
-rw-r--r--net/netsaint/files/patch-ba20
2 files changed, 21 insertions, 0 deletions
diff --git a/net/netsaint/Makefile b/net/netsaint/Makefile
index f3d3d1593e0a..85000a689d1f 100644
--- a/net/netsaint/Makefile
+++ b/net/netsaint/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netsaint
PORTVERSION= 0.0.7
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://netsaint.sourceforge.net/download/ \
diff --git a/net/netsaint/files/patch-ba b/net/netsaint/files/patch-ba
new file mode 100644
index 000000000000..c4b47eabff35
--- /dev/null
+++ b/net/netsaint/files/patch-ba
@@ -0,0 +1,20 @@
+--- base/utils.c.orig Thu Feb 21 02:47:12 2002
++++ base/utils.c Tue Jun 11 09:21:53 2002
+@@ -1884,6 +1884,17 @@
+ val|=FD_CLOEXEC;
+ fcntl(lockfile,F_SETFD,val);
+
++ /* close existing stdin, stdout, stderr */
++ close(0);
++ close(1);
++ close(2);
++
++ /* THIS HAS TO BE DONE TO AVOID PROBLEMS WITH STDERR BEING REDIRECTED TO SERVICE MESSAGE PIPE! */
++ /* re-open stdin, stdout, stderr with known values */
++ open("/dev/null",O_RDONLY);
++ open("/dev/null",O_WRONLY);
++ open("/dev/null",O_WRONLY);
++
+ return OK;
+ }
+