aboutsummaryrefslogtreecommitdiffstats
path: root/net/ngrep
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-05-03 11:00:21 +0800
committeredwin <edwin@FreeBSD.org>2006-05-03 11:00:21 +0800
commit14dfc3803923134c0c6e64a3385f73e7fae6f7a0 (patch)
tree3dc60c6c114149b86b291dec9dfb6c90bbcb274b /net/ngrep
parent3ea76c715626f6ee3c84ab50b7124c43fa95605e (diff)
downloadfreebsd-ports-gnome-14dfc3803923134c0c6e64a3385f73e7fae6f7a0.tar.gz
freebsd-ports-gnome-14dfc3803923134c0c6e64a3385f73e7fae6f7a0.tar.zst
freebsd-ports-gnome-14dfc3803923134c0c6e64a3385f73e7fae6f7a0.zip
[patch] net/ngrep segfaults at startup on amd64
# ngrep Segmentation fault: 11 (core dumped) [ etc :-) ] PR: ports/95612 Submitted by: Vasil Dimov <vd@FreeBSD.org>
Diffstat (limited to 'net/ngrep')
-rw-r--r--net/ngrep/Makefile1
-rw-r--r--net/ngrep/files/patch-ngrep.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index b10d21095e95..4e6fdb74101c 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ngrep
PORTVERSION= 1.44
+PORTREVISION= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/ngrep/files/patch-ngrep.c b/net/ngrep/files/patch-ngrep.c
new file mode 100644
index 000000000000..42a398ea09d9
--- /dev/null
+++ b/net/ngrep/files/patch-ngrep.c
@@ -0,0 +1,10 @@
+--- ngrep.c.orig Tue Apr 11 09:20:31 2006
++++ ngrep.c Tue Apr 11 09:20:59 2006
+@@ -15,6 +15,7 @@
+ #include <netinet/in.h>
+ #include <netinet/in_systm.h>
+ #include <net/if.h>
++#include <arpa/inet.h>
+ #include <sys/tty.h>
+ #include <pwd.h>
+ #endif