aboutsummaryrefslogtreecommitdiffstats
path: root/net/ngrep
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-02-24 14:28:20 +0800
committeredwin <edwin@FreeBSD.org>2005-02-24 14:28:20 +0800
commit22f513b441885a9198adb2c2f4fc3d48ba391ab4 (patch)
tree226b44ed7959bbe8d4daacd9e100c9346f86793f /net/ngrep
parent89790cd276b9c062da24281602120c77e6c4ddbc (diff)
downloadfreebsd-ports-gnome-22f513b441885a9198adb2c2f4fc3d48ba391ab4.tar.gz
freebsd-ports-gnome-22f513b441885a9198adb2c2f4fc3d48ba391ab4.tar.zst
freebsd-ports-gnome-22f513b441885a9198adb2c2f4fc3d48ba391ab4.zip
Upgrade to version 1.43
v1.43 o healed the win32 code fork: ngrep now builds from the same source tree for all platforms including Windows o re-wrote the privilege revocation logic after problems were reported with the SPC version, and removed non-root drop_privs capability altogether o fix off-by-one bug which caused ngrep to exit 1 packet early when ``-A'' as invoked o Fixed problematic configtest for old broken-redhat-glibc UDP header o ngrep now sets a pcap filter "ip" by default, if one is not specified o header offset fix to 802.11 processing o support IGMP and Raw (unknown IP protocol) type packets o support for latest versions of libpcap (0.8.3) and winpcap (3.1 beta 4) o updated configure to autoconf 2.59, and config.guess and config.sub to latest versions o updated PCRE from 3.4 to 5.0 o and various minor changes and updates to improve ngrep
Diffstat (limited to 'net/ngrep')
-rw-r--r--net/ngrep/Makefile15
-rw-r--r--net/ngrep/distinfo4
-rw-r--r--net/ngrep/files/patch-Makefile.in11
-rw-r--r--net/ngrep/files/patch-ngrep.c12
4 files changed, 23 insertions, 19 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 0cd7c62d3084..f811f619c53e 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= ngrep
-PORTVERSION= 1.42
-PORTREVISION= 1
+PORTVERSION= 1.43
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,14 +18,16 @@ COMMENT= Network grep
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcre \
--disable-pcap-restart \
- --enable-dropprivs-onlyroot
+ --enable-dropprivs-onlyroot \
+ --mandir=${PREFIX}/man/
ALL_TARGET= ngrep
USE_BZIP2= yes
MAN8= ngrep.8
PLIST_FILES= bin/ngrep
-PORTDOCS= BUGS CHANGES CREDITS INSTALL LICENSE README README.pcre TODO
+PORTDOCS= CHANGES.txt CREDITS.txt INSTALL.txt LICENSE.txt \
+ README.txt REGEX.txt
.include <bsd.port.pre.mk>
@@ -34,7 +35,11 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @if [ -f ${WRKSRC}/${file} ]; then \
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}; \
+ else \
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}; \
+ fi
.endfor
.endif
diff --git a/net/ngrep/distinfo b/net/ngrep/distinfo
index 2cf894b501eb..7ac902da4be0 100644
--- a/net/ngrep/distinfo
+++ b/net/ngrep/distinfo
@@ -1,2 +1,2 @@
-MD5 (ngrep-1.42.tar.bz2) = 35e821cfd888e9523a90fb7e5074a072
-SIZE (ngrep-1.42.tar.bz2) = 527699
+MD5 (ngrep-1.43.tar.bz2) = 835e7b52a45c55637f2435a79c7b570c
+SIZE (ngrep-1.43.tar.bz2) = 447819
diff --git a/net/ngrep/files/patch-Makefile.in b/net/ngrep/files/patch-Makefile.in
new file mode 100644
index 000000000000..61eb3d072ceb
--- /dev/null
+++ b/net/ngrep/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Feb 24 17:24:22 2005
++++ Makefile.in Thu Feb 24 17:24:27 2005
+@@ -25,7 +25,7 @@
+
+ bindir = $(prefix)/bin
+ datadir = $(prefix)/share
+-mandir = $(datadir)/man
++mandir = $(prefix)/man
+
+ BINDIR_INSTALL = $(prefix)/bin
+ MANDIR_INSTALL = $(mandir)/man8
diff --git a/net/ngrep/files/patch-ngrep.c b/net/ngrep/files/patch-ngrep.c
deleted file mode 100644
index 6d6c5d2290db..000000000000
--- a/net/ngrep/files/patch-ngrep.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ngrep.c.orig Fri Apr 9 13:09:16 2004
-+++ ngrep.c Fri Apr 9 13:09:22 2004
-@@ -54,8 +54,8 @@
- #include <netinet/udp.h>
- #include <netinet/ip_icmp.h>
-
--#include <pcap.h>
- #include <net/bpf.h>
-+#include <pcap.h>
-
- #include <stdlib.h>
- #include <string.h>