aboutsummaryrefslogtreecommitdiffstats
path: root/net/nmsg
diff options
context:
space:
mode:
authortruckman <truckman@FreeBSD.org>2016-12-05 13:57:51 +0800
committertruckman <truckman@FreeBSD.org>2016-12-05 13:57:51 +0800
commit3b38773236557dfa4d11204d39962a737899ba8f (patch)
tree56c26c6955b9811730fb74cec7f7fd9b8db68eda /net/nmsg
parent6b6929c085a28e2feebe2e1447fba703f8964570 (diff)
downloadfreebsd-ports-gnome-3b38773236557dfa4d11204d39962a737899ba8f.tar.gz
freebsd-ports-gnome-3b38773236557dfa4d11204d39962a737899ba8f.tar.zst
freebsd-ports-gnome-3b38773236557dfa4d11204d39962a737899ba8f.zip
Upgrade net/nmsg to version 0.12.1:
nmsg (0.12.1) * Revert "Don't leak duplicate XS endpoint string in parsing code." -- Farsight Security, Inc. <software@fsi.io> Mon, 28 Nov 2016 18:52:41 +0000 nmsg (0.12.0) * Add nmsg_message_get_payload_size() to return the size of the serialized payload object. * Add dnstap message module support. dnstap is a flexible, structured event replication format for DNS software. * nmsg_output_set_rate: Do not destroy existing rate as another output may be using it. Note the changed behavior: The caller of nmsg_output_set_rate() is responsible for reclaiming unused nmsg_rate_t objects with nmsg_rate_destroy(). * Use output lock in nmsg_output_set_rate(). * Fix sizeof operands in nmsg_chalias_lookup() memory allocations. * Fix potential uninitialized filter result in io_run_filters(). * Replace enum-exhaustive if/else with switch for msgmod. * Fix potential nmsg_pres_to_payload crash from unknown fields in msgmod. * Remove unnecessary initializations in strbuf code. * Add missing cleanup in nmsg_pcap_input_setfilter_raw error returns. * Refactor io loop close check to remove unused return value. * Fix ignored return value in file input. * Don't leak duplicate XS endpoint string in parsing code * Fix problems with nmsg_output_set_rate(). It destroys a previously provided nmsg_rate. If that rate object is shared with another output, activity on the other output will access freed memory formerly associated with that nmsg_rate. It does not synchronize setting the nmsg_rate object. This can lead to race conditions, e.g. if the rate object is set and the old one destroyed while an output is in nmsg_rate_sleep(). -- Farsight Security, Inc. <software@fsi.io> Wed, Nov 23 2016 21:15:55 +0000 Consistently use %%DATADIR%% in pkg_plist. Sponsored by: Farsight Security, Inc.
Diffstat (limited to 'net/nmsg')
-rw-r--r--net/nmsg/Makefile2
-rw-r--r--net/nmsg/distinfo5
-rw-r--r--net/nmsg/pkg-plist26
3 files changed, 18 insertions, 15 deletions
diff --git a/net/nmsg/Makefile b/net/nmsg/Makefile
index e9696a0bba4d..9b20b7171be5 100644
--- a/net/nmsg/Makefile
+++ b/net/nmsg/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nmsg
-PORTVERSION= 0.11.2
+PORTVERSION= 0.12.1
CATEGORIES= net
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
diff --git a/net/nmsg/distinfo b/net/nmsg/distinfo
index e071c92fdec6..7e3da2c8f883 100644
--- a/net/nmsg/distinfo
+++ b/net/nmsg/distinfo
@@ -1,2 +1,3 @@
-SHA256 (nmsg-0.11.2.tar.gz) = 9a8f02f4b3796fc5733f119825a81a5ea356231b953f2765f362220520b953b3
-SIZE (nmsg-0.11.2.tar.gz) = 621053
+TIMESTAMP = 1480706696
+SHA256 (nmsg-0.12.1.tar.gz) = 68632b5505e03bdd476f5f4a9e648c3a881440fc8ff8ab0d8d9af5faf10c105f
+SIZE (nmsg-0.12.1.tar.gz) = 620784
diff --git a/net/nmsg/pkg-plist b/net/nmsg/pkg-plist
index a74913aff56c..2777e76eaf4e 100644
--- a/net/nmsg/pkg-plist
+++ b/net/nmsg/pkg-plist
@@ -5,6 +5,7 @@ include/nmsg/asprintf.h
include/nmsg/base/defs.h
include/nmsg/base/dns.pb-c.h
include/nmsg/base/dnsqr.pb-c.h
+include/nmsg/base/dnstap.pb-c.h
include/nmsg/base/email.pb-c.h
include/nmsg/base/encode.pb-c.h
include/nmsg/base/http.pb-c.h
@@ -48,18 +49,19 @@ lib/nmsg/nmsg_flt1_sample.so
lib/nmsg/nmsg_msg9_base.so
libdata/pkgconfig/libnmsg.pc
%%MANPAGES%%man/man1/nmsgtool.1.gz
-share/nmsg/base/dns.proto
-share/nmsg/base/dnsqr.proto
-share/nmsg/base/email.proto
-share/nmsg/base/encode.proto
-share/nmsg/base/http.proto
-share/nmsg/base/ipconn.proto
-share/nmsg/base/linkpair.proto
-share/nmsg/base/logline.proto
-share/nmsg/base/ncap.proto
-share/nmsg/base/packet.proto
-share/nmsg/base/pkt.proto
-share/nmsg/base/xml.proto
+%%DATADIR%%/base/dns.proto
+%%DATADIR%%/base/dnsqr.proto
+%%DATADIR%%/base/dnstap.proto
+%%DATADIR%%/base/email.proto
+%%DATADIR%%/base/encode.proto
+%%DATADIR%%/base/http.proto
+%%DATADIR%%/base/ipconn.proto
+%%DATADIR%%/base/linkpair.proto
+%%DATADIR%%/base/logline.proto
+%%DATADIR%%/base/ncap.proto
+%%DATADIR%%/base/packet.proto
+%%DATADIR%%/base/pkt.proto
+%%DATADIR%%/base/xml.proto
%%EXAMPLES%%%%EXAMPLESDIR%%/email_client.c
%%EXAMPLES%%%%EXAMPLESDIR%%/email_client_postfix.py
%%EXAMPLES%%%%EXAMPLESDIR%%/http_client.c