aboutsummaryrefslogtreecommitdiffstats
path: root/net/nss_ldap
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2011-02-18 16:41:07 +0800
committermartymac <martymac@FreeBSD.org>2011-02-18 16:41:07 +0800
commitb5a317f097154aed5bf3b186113f56574b25e0e6 (patch)
tree94339e46fb5e67c12eacc45d10c4e7c91d061531 /net/nss_ldap
parentfd64c1822d2a65de509b073a02922a8e11c2df05 (diff)
downloadfreebsd-ports-gnome-b5a317f097154aed5bf3b186113f56574b25e0e6.tar.gz
freebsd-ports-gnome-b5a317f097154aed5bf3b186113f56574b25e0e6.tar.zst
freebsd-ports-gnome-b5a317f097154aed5bf3b186113f56574b25e0e6.zip
- Fix several default paths relative to PREFIX
- Move REINPLACE_CMDs to the post-patch target to avoid patching the same files again when re-running the install target - Provide a .conf file from the .conf.sample one - Add a LOCAL mirror PR: 154843 Approved by: Michael Graziano <mikeg@bsd-box.net> (maintainer), ehaupt (mentor) Feature safe: yes
Diffstat (limited to 'net/nss_ldap')
-rw-r--r--net/nss_ldap/Makefile20
-rw-r--r--net/nss_ldap/distinfo1
-rw-r--r--net/nss_ldap/pkg-plist4
3 files changed, 17 insertions, 8 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 41c84147fc0a..bd313591cf79 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -7,9 +7,10 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
-MASTER_SITES= http://www.padl.com/download/
+MASTER_SITES= http://www.padl.com/download/ \
+ LOCAL/martymac
DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}
MAINTAINER= mikeg@bsd-box.net
@@ -27,9 +28,6 @@ USE_OPENLDAP= yes
OPTIONS= LCLASS "Enable login classes via the loginClass attribute" on
-PLIST_FILES= etc/nss_ldap.conf.sample \
- lib/nss_ldap.so.1
-
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib"
@@ -54,6 +52,13 @@ CFLAGS+="-DHAVE_LOGIN_CLASSES"
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/ldap\.,${PREFIX}/etc/nss_ldap.,g' \
+ -e 's,/etc/openldap/ldap\.,${PREFIX}/etc/openldap/ldap.,g' \
+ ${WRKSRC}/ldap.conf
+ @${REINPLACE_CMD} 's,/etc/ldap\.,${PREFIX}/etc/nss_ldap.,g' \
+ ${WRKSRC}/${MAN5}
+
# XXX: newer autoconf's rely on the compiler result, not the preprocessor
# for checking headers, so the configure.in needs to be fixed upstream
# to properly include dependencies
@@ -65,11 +70,12 @@ post-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${PREFIX}/lib/nss_ldap.so.1
${INSTALL_DATA} ${WRKSRC}/ldap.conf ${PREFIX}/etc/nss_ldap.conf.sample
- @${REINPLACE_CMD} 's,/etc/ldap.,${PREFIX}/etc/nss_ldap.,g' \
- ${WRKSRC}/${MAN5}
${INSTALL_MAN} ${WRKSRC}/${MAN5} ${MAN5PREFIX}/man/man5
post-install:
+.if !exists(${PREFIX}/etc/nss_ldap.conf)
+ ${CP} -p ${PREFIX}/etc/nss_ldap.conf.sample ${PREFIX}/etc/nss_ldap.conf
+.endif
.if !defined(PACKAGE_BUILDING)
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/net/nss_ldap/distinfo b/net/nss_ldap/distinfo
index 6e10f4020466..e2f1dbe5a5a1 100644
--- a/net/nss_ldap/distinfo
+++ b/net/nss_ldap/distinfo
@@ -1,3 +1,2 @@
-MD5 (nss_ldap-265.tar.gz) = c1cb02d1a85538cf16bca6f6a562abe4
SHA256 (nss_ldap-265.tar.gz) = 77b54d905f50d774f28d5559d49126f1bc76720f741b0864a64bb4936ec226a8
SIZE (nss_ldap-265.tar.gz) = 280976
diff --git a/net/nss_ldap/pkg-plist b/net/nss_ldap/pkg-plist
new file mode 100644
index 000000000000..451b8f763c3f
--- /dev/null
+++ b/net/nss_ldap/pkg-plist
@@ -0,0 +1,4 @@
+lib/nss_ldap.so.1
+@unexec if cmp -s %D/etc/nss_ldap.conf %D/etc/nss_ldap.conf.sample; then rm -f %D/etc/nss_ldap.conf; fi
+etc/nss_ldap.conf.sample
+@exec if [ ! -f %D/etc/nss_ldap.conf ]; then cp %B/%f %D/etc/nss_ldap.conf; fi