aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntop/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-07-22 09:19:36 +0800
committerpav <pav@FreeBSD.org>2007-07-22 09:19:36 +0800
commit053bed776549eee300fe7704fb732914e2c5f7a4 (patch)
tree4365ae6e1280c9d6d08dd1c64281c15f0831b15a /net/ntop/Makefile
parent2b15b36833ef599dc5412019bfb3a8ec590cd120 (diff)
downloadfreebsd-ports-gnome-053bed776549eee300fe7704fb732914e2c5f7a4.tar.gz
freebsd-ports-gnome-053bed776549eee300fe7704fb732914e2c5f7a4.tar.zst
freebsd-ports-gnome-053bed776549eee300fe7704fb732914e2c5f7a4.zip
- Update to 3.3
PR: ports/114681 Submitted by: Wesley Shields <wxs@atarininja.org> (maintainer)
Diffstat (limited to 'net/ntop/Makefile')
-rw-r--r--net/ntop/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index cf9e60bf4846..aa95d4c73997 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -6,35 +6,31 @@
#
PORTNAME= ntop
-PORTVERSION= 3.2
-PORTREVISION= 5
+PORTVERSION= 3.3
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
-EXTRACT_SUFX= .tgz
MAINTAINER= wxs@atarininja.org
COMMENT= Network monitoring tool with command line and web interfaces
+BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
gdbm.3:${PORTSDIR}/databases/gdbm \
png.5:${PORTSDIR}/graphics/png
-
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
- ${X11BASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
+ ${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
DBDIR?= /var/db
-USE_AUTOTOOLS= libtool:15
-USE_GETOPT_LONG=yes
+USE_AUTOTOOLS= libtool:15 automake:19 autoconf:259
USE_GNOME= libxml2
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= DBDIR=${DBDIR} \
- SHLIB=${PORTVERSION:S/.p/pre/}
+ PORTVERSION=${PORTVERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-ossl-root=${OPENSSLBASE} \
@@ -86,7 +82,6 @@ CONFIGURE_ARGS+= --enable-i18n \
.endif
.if defined(WITH_XMLDUMP)
-BROKEN= Does not build with XML dump support
LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
@@ -104,6 +99,9 @@ PLIST_SUB+= ASDATA="@comment "
post-extract:
@${RM} ${WRKSRC}/configureextra/FREEBSD
+pre-configure:
+ @cd ${WRKSRC} && ${SH} autogen.sh --noconfig
+
post-install:
@${MKDIR} ${DBDIR}/ntop
@${CHOWN} -R nobody:nobody ${DBDIR}/ntop