aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntop/files
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-06-24 22:51:21 +0800
committerwjv <wjv@FreeBSD.org>2002-06-24 22:51:21 +0800
commit6b041ef06c9425e7bc61cbd65409de7f535f1d5f (patch)
treecfb30b72801f69a884deb016a4f0a93b8811f8cc /net/ntop/files
parent4b9fd9d1ba3656ab091c58e4b1fa410c0a6b2b7d (diff)
downloadfreebsd-ports-gnome-6b041ef06c9425e7bc61cbd65409de7f535f1d5f.tar.gz
freebsd-ports-gnome-6b041ef06c9425e7bc61cbd65409de7f535f1d5f.tar.zst
freebsd-ports-gnome-6b041ef06c9425e7bc61cbd65409de7f535f1d5f.zip
- Update to version 2.0.99.r2 which is only a release candidate, but there
has been a "massive public demand" that this port be unFORBIDDEN. - Remove FORBIDDEN. - Add a PKGMESSAGE to explain new post-install procedure, and to warn the user that this port/package is likely to have future security issues. - Install startup script mode 444, forcing the user to change this explicitly to run ntop at system startup. Document this in PKGMESSAGE.
Diffstat (limited to 'net/ntop/files')
-rw-r--r--net/ntop/files/ntop.sh4
-rw-r--r--net/ntop/files/patch-Makefile.am19
-rw-r--r--net/ntop/files/patch-configure.in26
-rw-r--r--net/ntop/files/patch-main.c11
4 files changed, 20 insertions, 40 deletions
diff --git a/net/ntop/files/ntop.sh b/net/ntop/files/ntop.sh
index e620e484b6d4..0bb75a6fedf9 100644
--- a/net/ntop/files/ntop.sh
+++ b/net/ntop/files/ntop.sh
@@ -19,7 +19,7 @@ http_port='3000'
https_port='3001'
# Directory for ntop.access.log
-logdir='/var/log'
+logdir='%%LOGDIR%%/ntop.access.log'
# Specify any additional arguments here - see ntop(8)
additional_args='-E'
@@ -42,7 +42,7 @@ start)
[ -d $logdir ] && touch ${logdir}/ntop.access.log \
&& chown $userid ${logdir}/ntop.access.log
[ -d %%PREFIX%%/share/ntop ] && cd %%PREFIX%%/share/ntop
- [ -x %%PREFIX%%/bin/ntop ] && %%PREFIX%%/bin/ntop $args \
+ [ -x %%PREFIX%%/bin/ntop ] && %%PREFIX%%/bin/ntop $args >/dev/null 2>&1 \
&& echo -n ' ntop'
;;
stop)
diff --git a/net/ntop/files/patch-Makefile.am b/net/ntop/files/patch-Makefile.am
index 72ef8187fcda..b25b6e5c70ca 100644
--- a/net/ntop/files/patch-Makefile.am
+++ b/net/ntop/files/patch-Makefile.am
@@ -1,23 +1,14 @@
---- Makefile.am.orig Thu Dec 27 18:00:25 2001
-+++ Makefile.am Tue Jan 8 14:31:14 2002
-@@ -145,7 +145,7 @@
- libntopreport_la_LIBADD = $(MORELIBS)
- libntopreport_la_LDFLAGS = -version-info @NTOP_VERSION_INFO@ -release @NTOP_RELEASE@ -export-dynamic @DYN_FLAGS@
-
--man_MANS = ntop.8 intop/intop.1
-+man_MANS = ntop.8 ntop-rules.8
-
- .PHONY: snapshot
-
-@@ -219,10 +219,10 @@
+--- Makefile.am.orig Tue May 14 20:12:55 2002
++++ Makefile.am Mon Jun 24 14:42:42 2002
+@@ -218,10 +218,10 @@
/bin/rm -f privkey.pem cert.pem
install-data-local:
-- @cp -p ntop-cert.pem $(bindir)/ntop-cert.pem
+- @cp -p ntop-cert.pem $(DESTDIR)$(bindir)/ntop-cert.pem
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(libdir)/plugins;
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop;
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop/html;
-+ @cp -p ntop-cert.pem $(datadir)/ntop/ntop-cert.pem
++ @cp -p ntop-cert.pem $(DESTDIR)/$(datadir)/ntop/ntop-cert.pem
@for file in $(NTOPHTML); do \
if test -d $$file; then \
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop/$$file; \
diff --git a/net/ntop/files/patch-configure.in b/net/ntop/files/patch-configure.in
index e800253bf19e..4986baf4543a 100644
--- a/net/ntop/files/patch-configure.in
+++ b/net/ntop/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Thu Dec 27 19:40:55 2001
-+++ configure.in Thu Jan 24 11:02:57 2002
-@@ -799,12 +799,10 @@
+--- configure.in.orig Fri May 31 12:09:35 2002
++++ configure.in Mon Jun 24 14:25:15 2002
+@@ -826,12 +826,10 @@
if test ".${GDBM_ROOT}" != .; then
AC_MSG_CHECKING([for the GNU Database Manager Library gdbm (required package)])
@@ -11,12 +11,12 @@
GDBM_ROOT=`cd ${GDBM_ROOT} && pwd`
- CORELIBS="${CORELIBS} -L$GDBM_ROOT -lgdbm"
- INCS="${INCS} -I$GDBM_ROOT"
-+ CORELIBS="${CORELIBS} -L$GDBM_ROOT/lib -lgdbm"
-+ INCS="${INCS} -I$GDBM_ROOT/include"
++ CORELIBS="${CORELIBS} -L${GDBM_ROOT}/lib -lgdbm"
++ INCS="${INCS} -I${GDBM_ROOT}/include"
AC_DEFINE(HAVE_GDBM_H)
AC_MSG_RESULT([found in $GDBM_ROOT])
else
-@@ -873,16 +871,11 @@
+@@ -907,16 +905,11 @@
dnl>
dnl> user defined directory passed as option at configuration time
dnl>
@@ -26,18 +26,18 @@
- test -r $GDCHART_ROOT/gdc.h &&
- test -r $GDCHART_ROOT/gd-1.8.3/libgd.a &&
- test -r $GDCHART_ROOT/gd-1.8.3/gd.h &&
-- test -r $GDCHART_ROOT/zlib-1.1.3/libz.a; then
+- test -r $GDCHART_ROOT/zlib-1.1.4/libz.a; then
+ if test 1; then
+ if test -d $GDCHART_ROOT; then
GDCHART_ROOT=`cd ${GDCHART_ROOT} && pwd`
-- MORELIBS="${MORELIBS} -L$GDCHART_ROOT -lgdchart -L$GDCHART_ROOT/gd-1.8.3 -lgd -L$GDCHART_ROOT/gd-1.8.3/libpng-1.0.8 -lpng -L$GDCHART_ROOT/zlib-1.1.3 -lz"
-- INCS="${INCS} -I$GDCHART_ROOT"
+- MORELIBS="${MORELIBS} -L$GDCHART_ROOT -lgdchart -L$GDCHART_ROOT/gd-1.8.3 -lgd -L$GDCHART_ROOT/gd-1.8.3/libpng-1.2.1 -lpng -L$GDCHART_ROOT/zlib-1.1.4 -lz"
+- INCS="${INCS} -I$GDCHART_ROOT -I$GDCHART_ROOT/zlib-1.1.4"
+ MORELIBS="${MORELIBS} -L${prefix}/lib -lgdchart -lgd -lpng -lz"
+ INCS="${INCS} -I${prefix}/include/gd"
AC_DEFINE(HAVE_GDCHART)
+ AC_DEFINE(HAVE_ZLIB)
AC_MSG_RESULT([found in $GDCHART_ROOT])
- else
-@@ -936,12 +929,10 @@
+@@ -971,12 +964,10 @@
if test ".$ac_disable_openssl" = ".no"; then
AC_MSG_CHECKING([for OpenSSL Library by Open SLL Project (optional package)])
if test ".${OSSL_ROOT}" != .; then
@@ -48,8 +48,8 @@
OSSL_ROOT=`cd ${OSSL_ROOT} && pwd`
- MORELIBS="${MORELIBS} -L$OSSL_ROOT -lssl"
- INCS="${INCS} -I$OSSL_ROOT"
-+ MORELIBS="${MORELIBS} -L$OSSL_ROOT/crypto -lssl"
-+ INCS="${INCS} -I$OSSL_ROOT/include"
++ MORELIBS="${MORELIBS} -L${OSSL_ROOT}/crypto -lssl"
++ INCS="${INCS} -I${OSSL_ROOT}/include"
AC_DEFINE(HAVE_OPENSSL)
AC_MSG_RESULT([found in $OSSL_ROOT])
elif test -d $OSSL_ROOT &&
diff --git a/net/ntop/files/patch-main.c b/net/ntop/files/patch-main.c
deleted file mode 100644
index 42e05291d303..000000000000
--- a/net/ntop/files/patch-main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.c.orig Tue Nov 13 13:44:26 2001
-+++ main.c Tue Dec 4 17:00:15 2001
-@@ -400,7 +400,7 @@
- }
-
- snprintf(accessLogPath, sizeof(accessLogPath), "%s/%s",
-- dbPath, DETAIL_ACCESS_LOG_FILE_PATH);
-+ accessLogPath, DETAIL_ACCESS_LOG_FILE_PATH);
-
- initLogger(); /* Do not call this function before dbPath
- is initialized */