aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntop
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-17 21:53:44 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-17 21:53:44 +0800
commit3d160a39ae3ebf16b600a84db34a5a7c0171aab2 (patch)
tree8e58173849e5000756701cb5e3848fe978eb6bbc /net/ntop
parentbf64f28e26a0e1bbf5dfa6cf0725e046caf3ffda (diff)
downloadfreebsd-ports-gnome-3d160a39ae3ebf16b600a84db34a5a7c0171aab2.tar.gz
freebsd-ports-gnome-3d160a39ae3ebf16b600a84db34a5a7c0171aab2.tar.zst
freebsd-ports-gnome-3d160a39ae3ebf16b600a84db34a5a7c0171aab2.zip
- Drop subversion dependency (not used, breaks build by touching ~)
- Cosmetic fixes PR: 190885 Submitted by: amdmi3
Diffstat (limited to 'net/ntop')
-rw-r--r--net/ntop/Makefile13
-rw-r--r--net/ntop/files/patch-autogen.sh30
2 files changed, 31 insertions, 12 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index c13f3223a523..a0bb1f79559b 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntop
PORTVERSION= 5.0.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Stable
@@ -15,7 +15,6 @@ LICENSE= GPLv3
LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm \
libevent-1.4.so:${PORTSDIR}/devel/libevent
BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
- subversion>=1.7.0:${PORTSDIR}/devel/subversion \
dot:${PORTSDIR}/graphics/graphviz \
geoiplookup:${PORTSDIR}/net/GeoIP
RUN_DEPENDS:= ${BUILD_DEPENDS} \
@@ -36,6 +35,7 @@ CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-ossl-root=${OPENSSLBASE} \
--with-gdbm-root=${LOCALBASE} \
--with-zlib-root=/usr
+INSTALL_TARGET= install-strip
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -49,10 +49,9 @@ OPTIONS_DEFINE= PCAP_PORT XMLDUMP JUMBO_FRAMES MAKO
PCAP_PORT_DESC= Use libpcap from ports
XMLDUMP_DESC= Enable XML Dump support
-JUMBO_FRAMES_DESC= Jumbo Frames. Experimental.
+JUMBO_FRAMES_DESC= Jumbo Frames (experimental)
MAKO_DESC= Install py-mako for Host Map, Region View
-.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPCAP_PORT}
@@ -80,14 +79,10 @@ CONFIGURE_ARGS+= --enable-jumbo-frames
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not configure on 6.X
-.endif
-
pre-configure:
@cd ${WRKSRC} && ${SETENV} ${SCRIPTS_ENV} ${SH} autogen.sh --noconfig
pre-install:
@cd ${WRKSRC} && ${GMAKE} dnetter
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ntop/files/patch-autogen.sh b/net/ntop/files/patch-autogen.sh
index 8430443e9293..bd9147fe77b4 100644
--- a/net/ntop/files/patch-autogen.sh
+++ b/net/ntop/files/patch-autogen.sh
@@ -1,6 +1,6 @@
---- ./autogen.sh.orig 2011-02-02 10:40:23.000000000 +0100
-+++ ./autogen.sh 2011-02-02 10:40:40.000000000 +0100
-@@ -202,16 +202,6 @@
+--- autogen.sh.orig 2012-02-20 14:35:43.000000000 +0400
++++ autogen.sh 2014-06-10 16:29:45.873177238 +0400
+@@ -202,30 +202,6 @@
GNU_OR_DIE=0
}
@@ -14,6 +14,30 @@
- GNU_OR_DIE=0
-}
-
+-if test "$GNU_OR_DIE" -eq 0; then
+- exit 1
+-fi
+-
+-SVN=`find_command 'svn'`
+-($SVN --version) < /dev/null > /dev/null 2>&1 ||
+-{
+- echo
+- echo "You must have svn/subversion installed to compile $progname."
+- echo "Download the appropriate package for your distribution, or get the"
+- echo "source from http://subversion.tigris.org"
+- GNU_OR_DIE=0
+-}
+-
if test "$GNU_OR_DIE" -eq 0; then
exit 1
fi
+@@ -442,7 +418,8 @@
+ if test -d nDPI; then
+ echo "nDPI already available"
+ else
+- svn co $NDPI_URL
++ echo "nDPI not bundled"
++ exit 1
+ fi
+
+ dnl> nDPI compilation