aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntop
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-07-22 09:19:36 +0800
committerpav <pav@FreeBSD.org>2007-07-22 09:19:36 +0800
commit053bed776549eee300fe7704fb732914e2c5f7a4 (patch)
tree4365ae6e1280c9d6d08dd1c64281c15f0831b15a /net/ntop
parent2b15b36833ef599dc5412019bfb3a8ec590cd120 (diff)
downloadfreebsd-ports-gnome-053bed776549eee300fe7704fb732914e2c5f7a4.tar.gz
freebsd-ports-gnome-053bed776549eee300fe7704fb732914e2c5f7a4.tar.zst
freebsd-ports-gnome-053bed776549eee300fe7704fb732914e2c5f7a4.zip
- Update to 3.3
PR: ports/114681 Submitted by: Wesley Shields <wxs@atarininja.org> (maintainer)
Diffstat (limited to 'net/ntop')
-rw-r--r--net/ntop/Makefile18
-rw-r--r--net/ntop/distinfo6
-rw-r--r--net/ntop/files/patch-Makefile.am (renamed from net/ntop/files/patch-Makefile.in)6
-rw-r--r--net/ntop/files/patch-configure70
-rw-r--r--net/ntop/files/patch-configure.in13
-rw-r--r--net/ntop/files/patch-libtool.m4.in11
-rw-r--r--net/ntop/files/patch-ntop.h11
-rw-r--r--net/ntop/files/patch-util.c12
-rw-r--r--net/ntop/pkg-plist112
9 files changed, 115 insertions, 144 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index cf9e60bf4846..aa95d4c73997 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -6,35 +6,31 @@
#
PORTNAME= ntop
-PORTVERSION= 3.2
-PORTREVISION= 5
+PORTVERSION= 3.3
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
-EXTRACT_SUFX= .tgz
MAINTAINER= wxs@atarininja.org
COMMENT= Network monitoring tool with command line and web interfaces
+BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
gdbm.3:${PORTSDIR}/databases/gdbm \
png.5:${PORTSDIR}/graphics/png
-
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
- ${X11BASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
+ ${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
DBDIR?= /var/db
-USE_AUTOTOOLS= libtool:15
-USE_GETOPT_LONG=yes
+USE_AUTOTOOLS= libtool:15 automake:19 autoconf:259
USE_GNOME= libxml2
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= DBDIR=${DBDIR} \
- SHLIB=${PORTVERSION:S/.p/pre/}
+ PORTVERSION=${PORTVERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-ossl-root=${OPENSSLBASE} \
@@ -86,7 +82,6 @@ CONFIGURE_ARGS+= --enable-i18n \
.endif
.if defined(WITH_XMLDUMP)
-BROKEN= Does not build with XML dump support
LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
@@ -104,6 +99,9 @@ PLIST_SUB+= ASDATA="@comment "
post-extract:
@${RM} ${WRKSRC}/configureextra/FREEBSD
+pre-configure:
+ @cd ${WRKSRC} && ${SH} autogen.sh --noconfig
+
post-install:
@${MKDIR} ${DBDIR}/ntop
@${CHOWN} -R nobody:nobody ${DBDIR}/ntop
diff --git a/net/ntop/distinfo b/net/ntop/distinfo
index 5b1027fc585b..b73a9dfdde71 100644
--- a/net/ntop/distinfo
+++ b/net/ntop/distinfo
@@ -1,3 +1,3 @@
-MD5 (ntop-3.2.tgz) = cd29a876b34a7dd76555e9acd8f160bb
-SHA256 (ntop-3.2.tgz) = 5b639dbcb3c8bf77824cf8aaed168864f69730b2ef41dc68d2db22b205c586d8
-SIZE (ntop-3.2.tgz) = 3910593
+MD5 (ntop-3.3.tar.gz) = a0e52a85587c8a5519d822d04862dab4
+SHA256 (ntop-3.3.tar.gz) = e849dabe0ac1ff006e487aef7b78fe06864b8d74a7b789fe6c7b8e258b7f361c
+SIZE (ntop-3.3.tar.gz) = 3709605
diff --git a/net/ntop/files/patch-Makefile.in b/net/ntop/files/patch-Makefile.am
index 51c7f2545cb9..9369510142e0 100644
--- a/net/ntop/files/patch-Makefile.in
+++ b/net/ntop/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- Makefile.in.orig Mon May 14 22:53:04 2007
-+++ Makefile.in Mon May 14 22:53:19 2007
-@@ -1359,7 +1359,6 @@
+--- ./Makefile.am.orig Sat Jun 9 17:15:11 2007
++++ ./Makefile.am Tue Jul 17 12:37:26 2007
+@@ -360,7 +360,6 @@
done
install-data-local: ntop.txt ntop.html faq.html
diff --git a/net/ntop/files/patch-configure b/net/ntop/files/patch-configure
deleted file mode 100644
index c2b8791b843e..000000000000
--- a/net/ntop/files/patch-configure
+++ /dev/null
@@ -1,70 +0,0 @@
---- configure.orig Tue Dec 21 05:07:24 2004
-+++ configure Sun Jan 16 10:19:25 2005
-@@ -5173,7 +5173,7 @@
- exit 1
- ;;
- *1\.3\.[45]\-freebsd\-ports*)
-- echo "* FreeBSD ports 1.3.4 seems to work, so we will let it slide..."
-+ echo "* FreeBSD ports 1.3.5 seems to work, so we will let it slide..."
- echo "*"
- echo "* Fasten your seat belt and good luck! If you are injured, the"
- echo "* development team will disavow any knowledge of your intentions."
-@@ -22928,13 +22928,13 @@
-
-
-
--echo "$as_me:$LINENO: checking for g_date_julian in -lglib" >&5
--echo $ECHO_N "checking for g_date_julian in -lglib... $ECHO_C" >&6
--if test "${ac_cv_lib_glib_g_date_julian+set}" = set; then
-+echo "$as_me:$LINENO: checking for g_date_new_julian in -lglib-2.0" >&5
-+echo $ECHO_N "checking for g_date_new_julian in -lglib-2.0... $ECHO_C" >&6
-+if test "${ac_cv_lib_glib_g_date_new_julian+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lglib $LIBS"
-+LIBS="-lglib-2.0 $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -22948,11 +22948,11 @@
- #endif
- /* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char g_date_julian ();
-+char g_date_new_julian ();
- int
- main ()
- {
--g_date_julian ();
-+g_date_new_julian ();
- ;
- return 0;
- }
-@@ -22997,7 +22997,7 @@
- #define HAVE_LIBGLIB 1
- _ACEOF
-
-- LIBS="-lglib $LIBS"
-+ LIBS="-lglib-2.0 $LIBS"
-
- fi
-
-@@ -28604,7 +28604,7 @@
- test ".${ac_cv_header_glibconfig_h}" = ".yes" &&
- test ".${ac_cv_header_xmlversion_h}" = ".yes" &&
- test ".${ac_cv_header_gdome_h}" = ".yes" &&
-- test ".${ac_cv_lib_glib_g_date_julian}" = ".yes" &&
-+ test ".${ac_cv_lib_glib_g_date_new_julian}" = ".yes" &&
- test ".${ac_cv_lib_xml2_xmlCheckVersion}" = ".yes" &&
- test ".${ac_cv_lib_gdome_gdome_di_saveDocToFile}" = ".yes"; then
- echo "$as_me:$LINENO: result: ok" >&5
-@@ -28623,7 +28623,7 @@
- echo "* gdome.h...${ac_cv_header_gdome_h}"
- echo "* libgdome.so or libgdome.a...${ac_cv_lib_gdome_gdome_di_saveDocToFile}"
- echo "* glib.h...${ac_cv_header_glib_h}"
-- echo "* libglib.so or libglib.a...${ac_cv_lib_glib_g_date_julian}"
-+ echo "* libglib.so or libglib.a...${ac_cv_lib_glib_g_date_new_julian}"
- echo "* glibconfig.h...${ac_cv_header_glibconfig_h}"
- echo "*"
- echo "* (yes means it was found, no means it was not found)"
diff --git a/net/ntop/files/patch-configure.in b/net/ntop/files/patch-configure.in
new file mode 100644
index 000000000000..984497fee14a
--- /dev/null
+++ b/net/ntop/files/patch-configure.in
@@ -0,0 +1,13 @@
+--- ./configure.in.orig Sat Jun 9 17:30:00 2007
++++ ./configure.in Tue Jul 17 12:37:26 2007
+@@ -577,8 +577,8 @@
+ dnl>
+ if test ".${PCAP_ROOT}" != .; then
+ if test -d $PCAP_ROOT &&
+- test -r $PCAP_ROOT/libpcap.a &&
+- test -r $PCAP_ROOT/pcap.h; then
++ test -r $PCAP_ROOT/lib/libpcap.a &&
++ test -r $PCAP_ROOT/include/pcap.h; then
+ PCAP_ROOT=`cd ${PCAP_ROOT} && pwd`
+ CORELIBS="${CORELIBS} -L$PCAP_ROOT -lpcap"
+ INCS="${INCS} -I$PCAP_ROOT"
diff --git a/net/ntop/files/patch-libtool.m4.in b/net/ntop/files/patch-libtool.m4.in
new file mode 100644
index 000000000000..ec46c77430bc
--- /dev/null
+++ b/net/ntop/files/patch-libtool.m4.in
@@ -0,0 +1,11 @@
+--- ./libtool.m4.in.orig Tue Jul 17 12:50:08 2007
++++ ./libtool.m4.in Tue Jul 17 12:50:13 2007
+@@ -1288,7 +1288,7 @@
+ ;;
+
+ freebsd*)
+- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
+ version_type=freebsd-$objformat
+ case $version_type in
+ freebsd-elf*)
diff --git a/net/ntop/files/patch-ntop.h b/net/ntop/files/patch-ntop.h
deleted file mode 100644
index f12499f5e385..000000000000
--- a/net/ntop/files/patch-ntop.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ntop.h.orig Mon Aug 1 12:07:39 2005
-+++ ntop.h Mon Aug 1 12:08:13 2005
-@@ -447,7 +447,7 @@
- #endif
-
- #ifndef EMBEDDED
--#include "rrd.h"
-+#include "myrrd/rrd.h"
- #endif
-
- #ifdef HAVE_GETOPT_H
diff --git a/net/ntop/files/patch-util.c b/net/ntop/files/patch-util.c
deleted file mode 100644
index abb1c662541a..000000000000
--- a/net/ntop/files/patch-util.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- util.c.orig Thu Dec 16 20:13:26 2004
-+++ util.c Sun Jan 16 12:05:04 2005
-@@ -494,7 +494,8 @@
- if(!strcmp(ii->name,device))
- if(iface_if_getinfo(ii) & IFACE_INFO_UP) {
- /* Allocate memory for IPv6 addresses*/
-- count = iface_if_addrcount(ii, AF_INET6);
-+ if ((count = iface_if_addrcount(ii, AF_INET6)) == 0)
-+ return NULL;
- if(count == 0) break;
- addrs = (NtopIfaceAddr *)calloc(count, sizeof(NtopIfaceAddr));
- addr_pos = 0;
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index 45cb8a8aee85..09316b21122b 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -7,52 +7,58 @@ etc/ntop/oui.txt.gz
etc/ntop/p2c.opt.table.gz
etc/ntop/specialMAC.txt.gz
@dirrm etc/ntop
-lib/libicmpPlugin-%%SHLIB%%.so
+lib/libicmpPlugin-%%PORTVERSION%%
+lib/libicmpPlugin
lib/libicmpPlugin.a
-lib/libicmpPlugin.so
-lib/liblastSeenPlugin-%%SHLIB%%.so
+lib/liblastSeenPlugin-%%PORTVERSION%%
+lib/liblastSeenPlugin
lib/liblastSeenPlugin.a
-lib/liblastSeenPlugin.so
-lib/libmyrrd.so
-lib/libmyrrd-%%SHLIB%%.so
-lib/libmyrrd.a
-lib/libmyrrd.la
-lib/libnetflowPlugin-%%SHLIB%%.so
+lib/libnetflowPlugin-%%PORTVERSION%%
+lib/libnetflowPlugin
lib/libnetflowPlugin.a
-lib/libnetflowPlugin.so
-lib/libntop-%%SHLIB%%.so
+lib/libntop-%%PORTVERSION%%
+lib/libntop
lib/libntop.a
lib/libntop.la
-lib/libntop.so
-lib/libntopreport-%%SHLIB%%.so
+lib/libntopreport-%%PORTVERSION%%
+lib/libntopreport
lib/libntopreport.a
lib/libntopreport.la
-lib/libntopreport.so
-lib/libpdaPlugin-%%SHLIB%%.so
+lib/libpdaPlugin-%%PORTVERSION%%
+lib/libpdaPlugin
lib/libpdaPlugin.a
-lib/libpdaPlugin.so
-lib/librrdPlugin-%%SHLIB%%.so
+lib/libremotePlugin-%%PORTVERSION%%
+lib/libremotePlugin
+lib/libremotePlugin.a
+lib/librrdPlugin-%%PORTVERSION%%
+lib/librrdPlugin
lib/librrdPlugin.a
-lib/librrdPlugin.so
-lib/libsflowPlugin-%%SHLIB%%.so
+lib/libsflowPlugin-%%PORTVERSION%%
+lib/libsflowPlugin
lib/libsflowPlugin.a
-lib/libsflowPlugin.so
-lib/libsnmpPlugin.so
-lib/libsnmpPlugin-%%SHLIB%%.so
-lib/libsnmpPlugin.a
-lib/libxmldumpPlugin-%%SHLIB%%.so
-lib/libxmldumpPlugin.a
-lib/libxmldumpPlugin.so
lib/ntop/plugins/icmpPlugin.so
lib/ntop/plugins/lastSeenPlugin.so
lib/ntop/plugins/netflowPlugin.so
lib/ntop/plugins/pdaPlugin.so
+lib/ntop/plugins/remotePlugin.so
lib/ntop/plugins/rrdPlugin.so
lib/ntop/plugins/sflowPlugin.so
-lib/ntop/plugins/snmpPlugin.so
-lib/ntop/plugins/xmldumpPlugin.so
@dirrm lib/ntop/plugins
@dirrm lib/ntop
+%%DATADIR%%/html/autosuggest.js
+%%DATADIR%%/html/calendar-setup.js
+%%DATADIR%%/html/calendar.js
+%%DATADIR%%/html/domLib.js
+%%DATADIR%%/html/domTT.js
+%%DATADIR%%/html/zoom.js
+%%DATADIR%%/html/calendar.gif
+%%DATADIR%%/html/edit.gif
+%%DATADIR%%/html/graph_zoom.gif
+%%DATADIR%%/html/marker.gif
+%%DATADIR%%/html/skype.gif
+%%DATADIR%%/html/external.png
+%%DATADIR%%/html/marker.png
+%%DATADIR%%/html/autosuggest.css
%%DATADIR%%/html/JSCookMenu.js
%%DATADIR%%/html/theme.js
%%DATADIR%%/html/arrow.gif
@@ -69,7 +75,6 @@ lib/ntop/plugins/xmldumpPlugin.so
%%DATADIR%%/html/arrow_down.gif
%%DATADIR%%/html/arrow_up.gif
%%DATADIR%%/html/back.gif
-%%DATADIR%%/html/bar.gif
%%DATADIR%%/html/bg_line.gif
%%DATADIR%%/html/black.gif
%%DATADIR%%/html/bottom_corner.gif
@@ -82,7 +87,6 @@ lib/ntop/plugins/xmldumpPlugin.so
%%DATADIR%%/html/clear.gif
%%DATADIR%%/html/clock.gif
%%DATADIR%%/html/collapsed.gif
-%%DATADIR%%/html/copyright.png
%%DATADIR%%/html/corner.gif
%%DATADIR%%/html/deleteURL.gif
%%DATADIR%%/html/deleteUser.gif
@@ -113,11 +117,7 @@ lib/ntop/plugins/xmldumpPlugin.so
%%DATADIR%%/html/mail.gif
%%DATADIR%%/html/major.gif
%%DATADIR%%/html/marchio_unipi_pant541_144.gif
-%%DATADIR%%/html/menubar.png
-%%DATADIR%%/html/menubar_j.png
-%%DATADIR%%/html/menuline.png
%%DATADIR%%/html/minor.gif
-%%DATADIR%%/html/modifyUser.gif
%%DATADIR%%/html/multihomed.gif
%%DATADIR%%/html/multivlaned.gif
%%DATADIR%%/html/nboxLogo.gif
@@ -126,7 +126,6 @@ lib/ntop/plugins/xmldumpPlugin.so
%%DATADIR%%/html/ntopdump.dtd
%%DATADIR%%/html/ntophelp.html
%%DATADIR%%/html/p2p.gif
-%%DATADIR%%/html/pie-error.png
%%DATADIR%%/html/phone.gif
%%DATADIR%%/html/printer.gif
%%DATADIR%%/html/privacyNotice.html
@@ -380,6 +379,49 @@ lib/ntop/plugins/xmldumpPlugin.so
%%DATADIR%%/html/web.gif
%%DATADIR%%/html/wheel.gif
%%DATADIR%%/html/white_bg.gif
+%%DATADIR%%/html/PlotKit/Base.js
+%%DATADIR%%/html/PlotKit/Canvas.js
+%%DATADIR%%/html/PlotKit/EasyPlot.js
+%%DATADIR%%/html/PlotKit/Layout.js
+%%DATADIR%%/html/PlotKit/PlotKit.js
+%%DATADIR%%/html/PlotKit/PlotKit_Packed.js
+%%DATADIR%%/html/PlotKit/SVG.js
+%%DATADIR%%/html/PlotKit/SweetCanvas.js
+%%DATADIR%%/html/PlotKit/SweetSVG.js
+%%DATADIR%%/html/PlotKit/excanvas.js
+%%DATADIR%%/html/MochiKit/Async.js
+%%DATADIR%%/html/MochiKit/Base.js
+%%DATADIR%%/html/MochiKit/Color.js
+%%DATADIR%%/html/MochiKit/DOM.js
+%%DATADIR%%/html/MochiKit/DateTime.js
+%%DATADIR%%/html/MochiKit/Format.js
+%%DATADIR%%/html/MochiKit/Iter.js
+%%DATADIR%%/html/MochiKit/Logging.js
+%%DATADIR%%/html/MochiKit/LoggingPane.js
+%%DATADIR%%/html/MochiKit/MochiKit.js
+%%DATADIR%%/html/MochiKit/MockDOM.js
+%%DATADIR%%/html/MochiKit/Signal.js
+%%DATADIR%%/html/MochiKit/Test.js
+%%DATADIR%%/html/MochiKit/Visual.js
+%%DATADIR%%/html/MochiKit/__package__.js
+%%DATADIR%%/html/img_inquisitor/as_pointer.gif
+%%DATADIR%%/html/img_inquisitor/hl_corner_bl.gif
+%%DATADIR%%/html/img_inquisitor/hl_corner_br.gif
+%%DATADIR%%/html/img_inquisitor/hl_corner_tl.gif
+%%DATADIR%%/html/img_inquisitor/hl_corner_tr.gif
+%%DATADIR%%/html/img_inquisitor/ul_corner_bl.gif
+%%DATADIR%%/html/img_inquisitor/ul_corner_br.gif
+%%DATADIR%%/html/img_inquisitor/ul_corner_tl.gif
+%%DATADIR%%/html/img_inquisitor/ul_corner_tr.gif
+%%DATADIR%%/html/jscalendar/calendar-load.js
+%%DATADIR%%/html/jscalendar/calendar-setup.js
+%%DATADIR%%/html/jscalendar/calendar.js
+%%DATADIR%%/html/jscalendar/lang/calendar-en.js
+@dirrm %%DATADIR%%/html/jscalendar/lang
+@dirrm %%DATADIR%%/html/jscalendar
+@dirrm %%DATADIR%%/html/img_inquisitor
+@dirrm %%DATADIR%%/html/MochiKit
+@dirrm %%DATADIR%%/html/PlotKit
@dirrm %%DATADIR%%/html/statsicons/flags
@dirrm %%DATADIR%%/html/statsicons/os
@dirrm %%DATADIR%%/html/statsicons