aboutsummaryrefslogtreecommitdiffstats
path: root/net/omnitty
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-05-26 16:40:54 +0800
committerclsung <clsung@FreeBSD.org>2006-05-26 16:40:54 +0800
commit0e358025ff930db23eef98e7421e8f387004902b (patch)
tree31aa77be0c28ba4a462d7b6be60be8a0d59fa24b /net/omnitty
parent0c6d9c8df480c0d0f99cd3f8db5db309f03fb698 (diff)
downloadfreebsd-ports-gnome-0e358025ff930db23eef98e7421e8f387004902b.tar.gz
freebsd-ports-gnome-0e358025ff930db23eef98e7421e8f387004902b.tar.zst
freebsd-ports-gnome-0e358025ff930db23eef98e7421e8f387004902b.zip
Add omnitty 0.3.0, a curses-based SSH multiplexer.
PR: ports/97942 Submitted by: Rong-En Fan <rafan@infor.org>
Diffstat (limited to 'net/omnitty')
-rw-r--r--net/omnitty/Makefile42
-rw-r--r--net/omnitty/distinfo3
-rw-r--r--net/omnitty/pkg-descr11
3 files changed, 56 insertions, 0 deletions
diff --git a/net/omnitty/Makefile b/net/omnitty/Makefile
new file mode 100644
index 000000000000..ea28714f6de4
--- /dev/null
+++ b/net/omnitty/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: omnitty
+# Date created: May 21 2006
+# Whom: Rong-En Fan <rafan@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= omnitty
+PORTVERSION= 0.3.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= rafan@infor.org
+COMMENT= A curses-based SSH multiplexer
+
+LIB_DEPENDS= rote:${PORTSDIR}/devel/rote
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+ALL_TARGET= ${PORTNAME}
+
+MAN1= ${PORTNAME}.1
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not work on FreeBSD 4.x
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} 's|<alloca.h>|<stdlib.h>|' \
+ ${WRKSRC}/machmgr.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.post.mk>
diff --git a/net/omnitty/distinfo b/net/omnitty/distinfo
new file mode 100644
index 000000000000..a0a52d72d5ad
--- /dev/null
+++ b/net/omnitty/distinfo
@@ -0,0 +1,3 @@
+MD5 (omnitty-0.3.0.tar.gz) = 5d35c4dfdc3194de94527e28a27d8461
+SHA256 (omnitty-0.3.0.tar.gz) = d17f3e97c05ff60c5bad0f9ef9b297e80023e8f0813f6d874fe35e2d516c7ba3
+SIZE (omnitty-0.3.0.tar.gz) = 51200
diff --git a/net/omnitty/pkg-descr b/net/omnitty/pkg-descr
new file mode 100644
index 000000000000..b7140e4a47fb
--- /dev/null
+++ b/net/omnitty/pkg-descr
@@ -0,0 +1,11 @@
+Omnitty is a curses-based program that allows one to log into several
+machines simultaneously and interact with them, selectively directing
+input to individual machines or groups of selected machines.
+
+You can run both line-oriented and screen oriented in the target
+machines, because Omnitty has built-in terminal emulation capability.
+When the window is large enough, Omnitty also displays a "summary area"
+for each machine, in which it shows what the latest output from the
+machine was, so you can have an idea of what is going on in each machine.
+
+WWW: http://omnitty.sourceforge.net/