aboutsummaryrefslogtreecommitdiffstats
path: root/net/opal/Makefile
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2000-02-21 21:27:29 +0800
committerroger <roger@FreeBSD.org>2000-02-21 21:27:29 +0800
commit5857ebede3d858a92639460cc8aff760af90ca13 (patch)
treeb64d05bf77d757f8df2609d03848e988c602181b /net/opal/Makefile
parentcbb8a5de6d6737c94f04d5dc43353ee06541d729 (diff)
downloadfreebsd-ports-gnome-5857ebede3d858a92639460cc8aff760af90ca13.tar.gz
freebsd-ports-gnome-5857ebede3d858a92639460cc8aff760af90ca13.tar.zst
freebsd-ports-gnome-5857ebede3d858a92639460cc8aff760af90ca13.zip
Import OpenH323 to ports/net.
(it was previously in ports/comms) OpenH323 is an H323 Video Conferencing Program, which can send and receive both audio and video with other H323 programs including Microsoft NetMeeting. It uses PWLib, the Portable Windows Library and PTLib Portable Toolkit Library from Equivalence Ltd Pty Note: at this time I've been unable to send audio, although audio can be received. For video, a Bt848/878 grabber (using the bktr driver) or a Matrox Meteor can be used. Obtained from: http://www.openh323.org
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
new file mode 100644
index 000000000000..eae4519938e1
--- /dev/null
+++ b/net/opal/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: openh323
+# Version required: 1.1alpha1
+# Date created: Thu Feb 17 15:00:48 GMT 2000
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= openh323_1.1alpha1
+PKGNAME= openh323-1.1.a1
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pwlib_min_1.14.tar.gz
+
+MAINTAINER= roger@freebsd.org
+
+WRKSRC= ${WRKDIR}/openh323
+
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
+ OPENH323DIR=${WRKDIR}/openh323
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/test/obj_FreeBSD_x86_r/voxilla ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/test/voxilla.1 ${PREFIX}/man/man1/voxilla.1
+
+MAN1= voxilla.1
+
+.include <bsd.port.mk>