aboutsummaryrefslogtreecommitdiffstats
path: root/net/opal/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2006-02-05 21:39:41 +0800
committernetchild <netchild@FreeBSD.org>2006-02-05 21:39:41 +0800
commitf39f5d89ebcd2e8fb4aea876a25e1b124f59f132 (patch)
treefa48a39235391ef75895ba7558df8e645b76dd0a /net/opal/Makefile
parent6733911da797352d7005a6319481056427e6a8d5 (diff)
downloadfreebsd-ports-gnome-f39f5d89ebcd2e8fb4aea876a25e1b124f59f132.tar.gz
freebsd-ports-gnome-f39f5d89ebcd2e8fb4aea876a25e1b124f59f132.tar.zst
freebsd-ports-gnome-f39f5d89ebcd2e8fb4aea876a25e1b124f59f132.zip
This is an initial port of newer versions of:
- pwlib -> 1.9.2 - openh323 -> 1.17.3 The decission of porting the development releases instead of the stable releases is based upon a discussion with the openh323 developers. They serve as a start to be able to porting newer versions of e.g. gnomemeeting et al. Further tweaks/improvements to them may be required when other ports start to use these versions. Unlike the previous versions of those ports, they install a shared lib now. So ports which depend upon them in the future should add a RUN_DEPENDS upon them. Additionally the build time for those ports will decrease, since they don't need to build pwlib/openh323 each time and grab them from the build directory. PR: 83396 Submitted by: Steve Ames <steve@energistic.com> In colaboration with: Steve Ames <steve@energistic.com>
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile58
1 files changed, 13 insertions, 45 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 5dbdfe458cfa..e0500c9efd6b 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -6,61 +6,29 @@
#
PORTNAME= openh323
-PORTVERSION= 1.12.2
-PORTREVISION= 1
+PORTVERSION= 1.17.3
CATEGORIES= net
-MASTER_SITES= http://www.openh323.org/bin/ \
- http://www.de.openh323.org/bin/ \
- http://www.gnomemeeting.org/downloads/0.98.0/sources/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= http://www.voxgratia.org/releases/
+DISTFILES= openh323-v1_17_3-src-tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= A H323 Video Conferencing library
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ pt_FreeBSD_x86_r.1:${PORTSDIR}/devel/pwlib
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-# Check for telephony.h in the two places the source is hard coded to check
-# /usr/include/sys and /usr/local/include/sys
-# If it is not present, extract it from the comms/ixj port
-.if !exists(/usr/include/sys/telephony.h)
-.if !exists(/usr/local/include/sys/telephony.h)
-PATCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
-.endif
-.endif
-.endif
+WRKSRC= ${WRKDIR}/openh323_v1_17_3
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-PLIST_FILES= bin/simph323
USE_BISON= yes
-
USE_GMAKE= yes
USE_OPENLDAP= yes
-USE_AUTOTOOLS= autoconf:259 autoconf:253:env
+USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
-PWLIBDIR!= cd ${PORTSDIR}/devel/pwlib && make -V WRKSRC
-CONFIGURE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
-ALL_TARGET= optnoshared
-MAKE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
-THE_MACHTYPE= ${ARCH:S/i386/x86/}
-MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
-
-post-patch:
-.if ${OSVERSION} < 500000
-.if !exists(/usr/include/sys/telephony.h)
-.if !exists(/usr/local/include/sys/telephony.h)
- # Copy ixj driver include files into OpenH323 include directory
- ${MKDIR} ${WRKDIR}/openh323/include/sys
- ${CP} ${WRKDIRPREFIX}${.CURDIR}/../../comms/ixj/work/ixj_freebsd/telephony.h ${WRKDIR}/openh323/include/sys
- ${CP} ${WRKDIRPREFIX}${.CURDIR}/../../comms/ixj/work/ixj_freebsd/ixjuser.h ${WRKDIR}/openh323/include/sys
-.endif
-.endif
-.endif
+INSTALLS_SHLIB= yes
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
+NO_FILTER_SHLIBS= yes
+ALL_TARGET= optshared
+MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>