aboutsummaryrefslogtreecommitdiffstats
path: root/net/opal3
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2006-04-21 21:03:32 +0800
committervs <vs@FreeBSD.org>2006-04-21 21:03:32 +0800
commitee91689edc885bf9567c797914aef7ba218c441c (patch)
tree117ee264387b182bf15aa5290d29a508de22fe84 /net/opal3
parenta5b463acd02fd4a65a39b67973bb4b6168d5bb22 (diff)
downloadfreebsd-ports-gnome-ee91689edc885bf9567c797914aef7ba218c441c.tar.gz
freebsd-ports-gnome-ee91689edc885bf9567c797914aef7ba218c441c.tar.zst
freebsd-ports-gnome-ee91689edc885bf9567c797914aef7ba218c441c.zip
Fix build on AMD
PR: ports/96102 Submitted by: maintainer
Diffstat (limited to 'net/opal3')
-rw-r--r--net/opal3/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index ef2c52fb2f26..8a691c50ee98 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -37,6 +37,11 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include
BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
.endif
+# Avoid build error on amd64: relocation R_X86_64_32 can not be used when making a shared object; recompile with -fPIC
+.if (${ARCH} == "amd64")
+CFLAGS+= -fPIC
+.endif
+
.ifdef (WITH_FFMPEG)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg