aboutsummaryrefslogtreecommitdiffstats
path: root/net/opal
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2002-01-15 23:06:17 +0800
committerroger <roger@FreeBSD.org>2002-01-15 23:06:17 +0800
commitb49241b9d8e9dea57bda280f2b150b0999ef8f84 (patch)
tree9bc143d856b0055b53241d926825740a0dfdd46f /net/opal
parentd564d7de53874a854fd5a996f5860535df3afc8b (diff)
downloadfreebsd-ports-gnome-b49241b9d8e9dea57bda280f2b150b0999ef8f84.tar.gz
freebsd-ports-gnome-b49241b9d8e9dea57bda280f2b150b0999ef8f84.tar.zst
freebsd-ports-gnome-b49241b9d8e9dea57bda280f2b150b0999ef8f84.zip
Make OpenH323 check for the ixj driver header files. If they
are not found, extract them from the ixj driver port and use them. This will make bento build packages for 4.x and 5.x with ixj support, even though the ixj driver fails to compile on 5.x systems at this point in time.
Diffstat (limited to 'net/opal')
-rw-r--r--net/opal/Makefile18
-rw-r--r--net/opal/files/patch-ab11
2 files changed, 25 insertions, 4 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index bebd1444e269..58e4a9cfb7e9 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.7.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
@@ -17,6 +17,12 @@ DISTFILES= openh323_1.7.4.tar.gz \
MAINTAINER= roger@freebsd.org
+# Check for telephony.h in /usr/include/sys and in $PREFIX/include/sys.
+# If it is not present, extract it from the comms/ixj port
+.if !exists(/usr/include/sys/telephony.h)
+BUILD_DEPENDS= ${PREFIX}/include/sys/telephony.h:${PORTSDIR}/comms/ixj:patch
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_NEWGCC= yes
@@ -29,6 +35,16 @@ MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+post-patch:
+.if !exists(/usr/include/sys/telephony.h)
+.if !exists($(PREFIX)/sys/telephony.h)
+ # Copy over ixj driver include files into OpenH323 include directory
+ ${MKDIR} ${WRKDIR}/openh323/include/sys
+ ${CP} ${PORTSDIR}/comms/ixj/work/ixj_freebsd/telephony.h ${WRKDIR}/openh323/include/sys
+ ${CP} ${PORTSDIR}/comms/ixj/work/ixj_freebsd/ixjuser.h ${WRKDIR}/openh323/include/sys
+.endif
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
diff --git a/net/opal/files/patch-ab b/net/opal/files/patch-ab
index 44efc143eb93..1d4daf2501a5 100644
--- a/net/opal/files/patch-ab
+++ b/net/opal/files/patch-ab
@@ -1,8 +1,8 @@
-*** openh323u.mak.orig Tue Jan 15 09:05:05 2002
---- openh323u.mak Tue Jan 15 09:05:41 2002
+*** openh323u.mak.orig Tue Oct 9 10:05:24 2001
+--- openh323u.mak Tue Jan 15 14:01:29 2002
*************** HAS_IXJ = 1
*** 124,129 ****
---- 124,134 ----
+--- 124,139 ----
STDCCFLAGS += -DHAS_IXJ
endif
@@ -11,6 +11,11 @@
+ STDCCFLAGS += -DHAS_IXJ -I/usr/local/include
+ endif
+
++ ifneq (,$(wildcard $(OPENH323DIR)/include/sys/telephony.h))
++ HAS_IXJ = 1
++ STDCCFLAGS += -DHAS_IXJ
++ endif
++
ifneq (,$(wildcard /usr/include/linux/soundcard.h))
HAS_OSS = 1
STDCCFLAGS += -DHAS_OSS