aboutsummaryrefslogtreecommitdiffstats
path: root/net/openbgpd
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-07-13 13:29:48 +0800
committerflz <flz@FreeBSD.org>2005-07-13 13:29:48 +0800
commit3c97ca39a2f52e43d69758ef6442a843fbddd9be (patch)
treeac8ae4f218a59e7afe39983e2908b8dacbaa31d0 /net/openbgpd
parentd2af213bb0d69a60695dee9119eb797a8c8a9260 (diff)
downloadfreebsd-ports-gnome-3c97ca39a2f52e43d69758ef6442a843fbddd9be.tar.gz
freebsd-ports-gnome-3c97ca39a2f52e43d69758ef6442a843fbddd9be.tar.zst
freebsd-ports-gnome-3c97ca39a2f52e43d69758ef6442a843fbddd9be.zip
- Update to 3.7.
PR: ports/83301 Submitted by: Babak Farrokhi <babak@farrokhi.net>
Diffstat (limited to 'net/openbgpd')
-rw-r--r--net/openbgpd/Makefile5
-rw-r--r--net/openbgpd/distinfo4
-rw-r--r--net/openbgpd/files/patch-bgpd_rde__filter.c13
3 files changed, 19 insertions, 3 deletions
diff --git a/net/openbgpd/Makefile b/net/openbgpd/Makefile
index 95e703998d55..4c8d581210dd 100644
--- a/net/openbgpd/Makefile
+++ b/net/openbgpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openbgpd
-PORTVERSION= 3.6
+PORTVERSION= 3.7
CATEGORIES= net
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenBGPD/:openbsd \
${MASTER_SITE_LOCAL:S/$/:freebsd/g}
@@ -53,6 +53,9 @@ post-patch:
${WRKSRC}/bgpd/bgpd.h \
${WRKSRC}/bgpd/bgpd.conf.5 \
${WRKSRC}/bgpctl/Makefile
+ @${REINPLACE_CMD} -e "s|__dead ||" \
+ ${WRKSRC}/bgpd/bgpd.c ${WRKSRC}/bgpctl/bgpctl.c
+ @${REINPLACE_CMD} -e "s|SIMPLEQ|STAILQ|" ${WRKSRC}/bgpd/*
do-build:
.for i in ${SUBDIRS}
diff --git a/net/openbgpd/distinfo b/net/openbgpd/distinfo
index 355886db62d5..6ab54b0f2bf6 100644
--- a/net/openbgpd/distinfo
+++ b/net/openbgpd/distinfo
@@ -1,5 +1,5 @@
-MD5 (openbgpd/openbgpd-3.6.tgz) = e40c5dce08c3c0e7fb232bdd5ea11523
-SIZE (openbgpd/openbgpd-3.6.tgz) = 109058
+MD5 (openbgpd/openbgpd-3.7.tgz) = 4d9d933a705a9b4154a86344e6eae437
+SIZE (openbgpd/openbgpd-3.7.tgz) = 114980
MD5 (openbgpd/if_media.h) = 4ff9297f5c133425dafe3ca565c0f811
SIZE (openbgpd/if_media.h) = 23762
MD5 (openbgpd/pfkey_compat.c) = 8c3bdf02fd308b327bd30e09674c1858
diff --git a/net/openbgpd/files/patch-bgpd_rde__filter.c b/net/openbgpd/files/patch-bgpd_rde__filter.c
new file mode 100644
index 000000000000..0484c7c18416
--- /dev/null
+++ b/net/openbgpd/files/patch-bgpd_rde__filter.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- bgpd/rde_filter.c.orig
++++ bgpd/rde_filter.c
+@@ -16,6 +16,7 @@
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+ #include <sys/types.h>
++#include <sys/limits.h>
+ #include <sys/queue.h>
+
+ #include <stdlib.h>