aboutsummaryrefslogtreecommitdiffstats
path: root/net/openbsc
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-11-21 19:52:15 +0800
committerpi <pi@FreeBSD.org>2015-11-21 19:52:15 +0800
commit4f6867e782cdd0bd815602cf682058ed3394d243 (patch)
tree13482a2ab96b81d55017d709edf027177da64117 /net/openbsc
parentf3f79bd5d8bd33daeb48078f022645e56d296d66 (diff)
downloadfreebsd-ports-gnome-4f6867e782cdd0bd815602cf682058ed3394d243.tar.gz
freebsd-ports-gnome-4f6867e782cdd0bd815602cf682058ed3394d243.tar.zst
freebsd-ports-gnome-4f6867e782cdd0bd815602cf682058ed3394d243.zip
net/openbsc: 0.14.0 -> 0.15.0
Changes: http://cgit.osmocom.org/openbsc/log/ PR: 204624 Submitted by: Nikola Kolev <koue@chaosophia.net> (maintainer)
Diffstat (limited to 'net/openbsc')
-rw-r--r--net/openbsc/Makefile22
-rw-r--r--net/openbsc/distinfo4
-rw-r--r--net/openbsc/files/patch-include-openbsc-mgcp.h14
-rw-r--r--net/openbsc/files/patch-include-openbsc-rtp.h15
-rw-r--r--net/openbsc/files/patch-src-libmsc-meas_feed.h13
-rw-r--r--net/openbsc/files/patch-src-libtrau-rtp_proxy.c15
-rw-r--r--net/openbsc/pkg-plist3
7 files changed, 23 insertions, 63 deletions
diff --git a/net/openbsc/Makefile b/net/openbsc/Makefile
index 860fbab193f5..4c7f5e1f7dfe 100644
--- a/net/openbsc/Makefile
+++ b/net/openbsc/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= openbsc
-PORTVERSION= 0.14.0
+PORTVERSION= 0.15.0
CATEGORIES= net
MASTER_SITES= http://git.osmocom.org/${PORTNAME}/snapshot/ \
http://chaosophia.net/downloads/osmocom/${PORTNAME}/
@@ -20,15 +20,29 @@ LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
USES= autoreconf compiler:c11 gmake pkgconfig
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT=yes
+OPENSSL_PORT= security/libressl
GNU_CONFIGURE=yes
AUTOMAKE_ARGS= --gnu --add-missing --copy
CONFIGURE_ARGS+= CFLAGS="-I${LOCALBASE}/include"
-OPTIONS_DEFINE= SQLITE
-OPTIONS_DEFAULT=
+OPTIONS_DEFINE= BSC NAT SQLITE
+OPTIONS_DEFAULT= BSC NAT
+
+BSC_DESC= Enable OSMO BSC
+NAT_DESC= Enable NAT support
+SQLITE_DESC= Enable SQLite support
OPTIONS_SUB= yes
-SQLITE_LIB_DEPENDS= libsqlite.so:${PORTSDIR}/databases/sqlite3
+
+BSC_CONFIGURE_ENABLE= osmo-bsc
+
+NAT_CONFIGURE_ENABLE= nat
+NAT_BUILD_DEPENDS= ${LOCALBASE}/lib/libsccp.a:${PORTSDIR}/devel/libosmo-sccp
+NAT_RUN_DEPENDS= ${LOCALBASE}/lib/libsccp.a:${PORTSDIR}/devel/libosmo-sccp
+
+SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
post-patch:
${REINPLACE_CMD} -e 's|pkgconfigdir.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g' \
diff --git a/net/openbsc/distinfo b/net/openbsc/distinfo
index 0a31ebd0e55e..259687322db3 100644
--- a/net/openbsc/distinfo
+++ b/net/openbsc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openbsc-0.14.0.tar.gz) = ae8f1b7ee89ea730492f790ca8c42bada1f863cf8867a853bae5f00f9e53aea0
-SIZE (openbsc-0.14.0.tar.gz) = 724745
+SHA256 (openbsc-0.15.0.tar.gz) = bb31c00c5b8d1e7c0c907f15b4450a53e9492609445a36a18eca755eb034f148
+SIZE (openbsc-0.15.0.tar.gz) = 749797
diff --git a/net/openbsc/files/patch-include-openbsc-mgcp.h b/net/openbsc/files/patch-include-openbsc-mgcp.h
deleted file mode 100644
index 95be64d7129d..000000000000
--- a/net/openbsc/files/patch-include-openbsc-mgcp.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- include/openbsc/mgcp.h.orig 2015-02-10 22:03:25 UTC
-+++ include/openbsc/mgcp.h
-@@ -31,6 +31,11 @@
-
- #include <arpa/inet.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/socket.h>
-+#include <netinet/in.h>
-+#endif
-+
- #define RTP_PORT_DEFAULT 4000
- #define RTP_PORT_NET_DEFAULT 16000
-
diff --git a/net/openbsc/files/patch-include-openbsc-rtp.h b/net/openbsc/files/patch-include-openbsc-rtp.h
deleted file mode 100644
index 4150e730667d..000000000000
--- a/net/openbsc/files/patch-include-openbsc-rtp.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- include/openbsc/rtp.h.orig 2015-02-10 22:03:25 UTC
-+++ include/openbsc/rtp.h
-@@ -10,6 +10,12 @@
- # define __BYTE_ORDER __DARWIN_BYTE_ORDER
- # define __LITTLE_ENDIAN __DARWIN_LITTLE_ENDIAN
- # define __BIG_ENDIAN __DARWIN_BIG_ENDIAN
-+# elif defined(__FreeBSD__)
-+# if __FreeBSD_version < 1000000
-+# include <machine/endian.h>
-+# else
-+# include <x86/endian.h>
-+# endif
- # else
- # error "__BYTE_ORDER should be defined by someone"
- # endif
diff --git a/net/openbsc/files/patch-src-libmsc-meas_feed.h b/net/openbsc/files/patch-src-libmsc-meas_feed.h
deleted file mode 100644
index f55e5f60f025..000000000000
--- a/net/openbsc/files/patch-src-libmsc-meas_feed.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/libmsc/meas_feed.h.orig 2015-02-10 22:03:25 UTC
-+++ src/libmsc/meas_feed.h
-@@ -3,6 +3,10 @@
-
- #include <stdint.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/socket.h>
-+#endif
-+
- int meas_feed_cfg_set(const char *dst_host, uint16_t dst_port);
- void meas_feed_cfg_get(char **host, uint16_t *port);
-
diff --git a/net/openbsc/files/patch-src-libtrau-rtp_proxy.c b/net/openbsc/files/patch-src-libtrau-rtp_proxy.c
deleted file mode 100644
index d68c380a0865..000000000000
--- a/net/openbsc/files/patch-src-libtrau-rtp_proxy.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/libtrau/rtp_proxy.c.orig 2015-02-10 22:03:25 UTC
-+++ src/libtrau/rtp_proxy.c
-@@ -47,6 +47,12 @@
- # define __BYTE_ORDER __DARWIN_BYTE_ORDER
- # define __LITTLE_ENDIAN __DARWIN_LITTLE_ENDIAN
- # define __BIG_ENDIAN __DARWIN_BIG_ENDIAN
-+# elif defined(__FreeBSD__)
-+# if __FreeBSD_version < 1000000
-+# include <machine/endian.h>
-+# else
-+# include <x86/endian.h>
-+# endif
- # else
- # error "__BYTE_ORDER should be defined by someone"
- # endif
diff --git a/net/openbsc/pkg-plist b/net/openbsc/pkg-plist
index bbe6a1eda6f7..5ffefd58b3df 100644
--- a/net/openbsc/pkg-plist
+++ b/net/openbsc/pkg-plist
@@ -6,6 +6,8 @@ bin/ipaccess-find
bin/ipaccess-config
bin/ipaccess-proxy
bin/osmo-gbproxy
+%%BSC%%bin/osmo-bsc
+%%NAT%%bin/osmo-bsc_nat
%%SQLITE%%bin/osmo-meas-udp2db
include/openbsc/gsm_04_08.h
include/openbsc/meas_rep.h
@@ -16,6 +18,7 @@ share/doc/openbsc/examples/osmo-bsc_mgcp/mgcp.cfg
share/doc/openbsc/examples/osmo-bsc_nat/black-list.cfg
share/doc/openbsc/examples/osmo-bsc_nat/osmo-bsc_nat.cfg
share/doc/openbsc/examples/osmo-gbproxy/osmo-gbproxy.cfg
+%%PORTDOCS%%%%DOCSDIR%%/examples/osmo-gbproxy/osmo-gbproxy-legacy.cfg
share/doc/openbsc/examples/osmo-nitb/bs11/openbsc-1bts-2trx-hopping.cfg
share/doc/openbsc/examples/osmo-nitb/bs11/openbsc-1bts-2trx.cfg
share/doc/openbsc/examples/osmo-nitb/bs11/openbsc-2bts-2trx.cfg