aboutsummaryrefslogtreecommitdiffstats
path: root/net/opengk/Makefile
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2001-10-08 20:14:34 +0800
committerroger <roger@FreeBSD.org>2001-10-08 20:14:34 +0800
commit4a69606ed307c79ac62879de2898e4e7e70f2e66 (patch)
tree30d57c42742eaa3d7631dcc71b7a6ca3d1c9ed7b /net/opengk/Makefile
parent94afe3f6f7beb2fc3da507d3b250e7cc02bc4047 (diff)
downloadfreebsd-ports-gnome-4a69606ed307c79ac62879de2898e4e7e70f2e66.tar.gz
freebsd-ports-gnome-4a69606ed307c79ac62879de2898e4e7e70f2e66.tar.zst
freebsd-ports-gnome-4a69606ed307c79ac62879de2898e4e7e70f2e66.zip
Add OpenGK, a H323 Gatekeeper written by Equivalence, who also write
the OpenH323 library. This Gatekeeper has a html interface via port 1719 for configuration.
Diffstat (limited to 'net/opengk/Makefile')
-rw-r--r--net/opengk/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/opengk/Makefile b/net/opengk/Makefile
new file mode 100644
index 000000000000..d7c095d837b3
--- /dev/null
+++ b/net/opengk/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: opengk
+# Date created: Mon Oct 8 12:49:00 BST 2001
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opengk
+PORTVERSION= 1.0.2
+CATEGORIES= net
+MASTER_SITES= http://www.openh323.org/bin/ \
+ http://www.de.openh323.org/bin/ \
+ http://www.ru.openh323.org/bin/
+DISTNAME= opengk_1.0.2
+
+MAINTAINER= roger@FreeBSD.org
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NOCLEANDEPENDS= yes
+
+USE_NEWGCC= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/opengk ${PREFIX}/bin
+
+.include <bsd.port.mk>