aboutsummaryrefslogtreecommitdiffstats
path: root/net/openh323/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-07 21:10:55 +0800
committerpav <pav@FreeBSD.org>2006-05-07 21:10:55 +0800
commitf30afaad87b6027a4366b38a9c65bb8644ec0e77 (patch)
treefd9e2f01002680b341f6fe9a711dc16ac24b7779 /net/openh323/Makefile
parent4d201a4ae37f6f71979d11e7672154d40aeb4573 (diff)
downloadfreebsd-ports-gnome-f30afaad87b6027a4366b38a9c65bb8644ec0e77.tar.gz
freebsd-ports-gnome-f30afaad87b6027a4366b38a9c65bb8644ec0e77.tar.zst
freebsd-ports-gnome-f30afaad87b6027a4366b38a9c65bb8644ec0e77.zip
- Enable RFC2190 codec support using ffmpeg, knob WITH_FFMPEG
- Support external speex, knob WITH_SPEEX - Remove indirect dependencies on expat and openldap (via pwlib) PR: ports/95423 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de> Approved by: Steve Ames <steve@energistic.com> (maintainer)
Diffstat (limited to 'net/openh323/Makefile')
-rw-r--r--net/openh323/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index 320d37495a39..fda8237498c6 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openh323
PORTVERSION= 1.18.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.voxgratia.org/releases/
DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
@@ -16,14 +16,12 @@ EXTRACT_SUFX= tar.gz
MAINTAINER= steve@energistic.com
COMMENT= A H323 Video Conferencing library
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- pt_r.1:${PORTSDIR}/devel/pwlib
+LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
USE_BISON= yes
USE_GMAKE= yes
-USE_OPENLDAP= yes
USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -36,6 +34,18 @@ NO_FILTER_SHLIBS= yes
.include <bsd.port.pre.mk>
+.ifdef (WITH_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --enable-rfc2190avcodec=${LOCALBASE}/include/ffmpeg
+.endif
+
+.ifdef (WITH_SPEEX)
+LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
+CONFIGURE_ARGS+= --enable-localspeex=no
+.else
+CONFIGURE_ARGS+= --enable-localspeex=yes
+.endif
+
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
.endif