aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap22-server
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-23 08:31:28 +0800
committeredwin <edwin@FreeBSD.org>2003-05-23 08:31:28 +0800
commiteb722826cfcd801d70e1fe7d023ce005720fccee (patch)
treebd61a79d7ee8fffdac3a4ffa0eb67408f14e61d0 /net/openldap22-server
parent5518fb34f4be7347c60fbb68c666f6fa7a639705 (diff)
downloadfreebsd-ports-gnome-eb722826cfcd801d70e1fe7d023ce005720fccee.tar.gz
freebsd-ports-gnome-eb722826cfcd801d70e1fe7d023ce005720fccee.tar.zst
freebsd-ports-gnome-eb722826cfcd801d70e1fe7d023ce005720fccee.zip
[PATCH] openldap21 port won't compile with any *_ONLY options
The openldap21 port won't compile with any of the possible options because of a recursive variable assignement. PR: ports/51419 Submitted by: Christophe Juniet <cjuniet@entreview.com>
Diffstat (limited to 'net/openldap22-server')
-rw-r--r--net/openldap22-server/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 8d5c15fff468..5a250f2c612f 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -72,14 +72,14 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} \
--enable-bdb \
--enable-crypt
-.if defined(WITHOUT_SASL)
+.if defined(WITHOUT_SASL)
CONFIGURE_ARGS+= \
--without-cyrus-sasl
.else
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= \
--with-cyrus-sasl \
- --enable-spasswd
+ --enable-spasswd
.endif
# ------------------------------------------------------------------------------
@@ -105,7 +105,7 @@ CONFIGURE_ARGS+= --enable-ipv6
#
BUILD_CLIENTS= yes
INSTALLS_SHLIB= yes
-PKGNAMESUFFIX= ${PKGNAMESUFFIX}-client
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-client
COMMENT= Open source LDAP client software
CONFIGURE_ARGS+= \
--disable-slapd \
@@ -118,7 +118,7 @@ CONFIGURE_ARGS+= \
# slapd only
#
BUILD_SLAPD= yes
-PKGNAMESUFFIX= ${PKGNAMESUFFIX}-slapd
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-slapd
COMMENT= Open source LDAP server software (slapd only)
LIB_DEPENDS+= ldap:${PORTSDIR}/net/openldap-client2.1
CONFIGURE_ARGS+= \
@@ -138,7 +138,7 @@ CONFIGURE_ARGS+= \
# and some backend we just don't install them later on
#
BUILD_SLURPD= yes
-PKGNAMESUFFIX= ${PKGNAMESUFFIX}-slurpd
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-slurpd
COMMENT= Open source LDAP server software (slurpd only)
LIB_DEPENDS+= ldap:${PORTSDIR}/net/openldap-client2.1
RUN_DEPENDS+= ${LOCALBASE}/libexec/slapd:${PORTSDIR}/net/openldap-slapd2.1
@@ -158,7 +158,7 @@ CONFIGURE_ARGS+= \
#
BUILD_SLAPD= yes
BUILD_SLURPD= yes
-PKGNAMESUFFIX= ${PKGNAMESUFFIX}-server
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-server
COMMENT= Open source LDAP server software (slapd and slurpd)
LIB_DEPENDS+= ldap:${PORTSDIR}/net/openldap-client2.1
CONFIGURE_ARGS+= \