aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap23-server/Makefile
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-05-02 07:56:17 +0800
committereik <eik@FreeBSD.org>2004-05-02 07:56:17 +0800
commit0efb0f4925217cf0af64a494db98046717f6bfc4 (patch)
tree505484574bcd0717d6e363b18ea52469c7f49dfd /net/openldap23-server/Makefile
parentd1a252e586143a370784778a8b5c433dfdfe49bc (diff)
downloadfreebsd-ports-gnome-0efb0f4925217cf0af64a494db98046717f6bfc4.tar.gz
freebsd-ports-gnome-0efb0f4925217cf0af64a494db98046717f6bfc4.tar.zst
freebsd-ports-gnome-0efb0f4925217cf0af64a494db98046717f6bfc4.zip
Fix upgrading via portupgrade, reported by Chuck Swiger <cswiger@mac.com>
Prepare for slave ports with SASL support
Diffstat (limited to 'net/openldap23-server/Makefile')
-rw-r--r--net/openldap23-server/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 29fc20f58db3..f8e91678d872 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -50,8 +50,13 @@ OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_CLIENT}
OPENLDAP_PKGFILESUFX= .client
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[013-9].* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[013-9].*
+.if defined(WITH_SASL)
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!2].*
+.else
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!2].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
+.endif
.if !defined(NOPORTDOCS)
PORTDOCS= drafts rfc
@@ -65,10 +70,17 @@ OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_SERVER}
OPENLDAP_PKGFILESUFX=
+.if defined(WITH_SASL)
+RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-sasl-client
+#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-sasl-client
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[!2].*
+.else
RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.202:${PORTSDIR}/net/openldap22-client
#RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.2.so.7:${PORTSDIR}/net/openldap22-client
-CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[013-9].*
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[!2].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.*
+.endif
.if ${PORTREVISION_CLIENT} != 0
SUF1_CLIENT= _${PORTREVISION_CLIENT}
@@ -131,7 +143,7 @@ INSTALLS_SHLIB= yes
USE_RC_SUBR= yes
-SED_SCRIPT+= -e 's,%%PKGNAME_CLIENT%%,${PKGNAME_CLIENT},g' \
+SED_SCRIPT+= -e 's,%%PKGNAME_CLIENT%%,${PKGNAME_CLIENT:R}.*,g' \
-e 's,%%RC_SUBR%%,${RC_SUBR},g' \
-e 's,%%RC_DIR%%,${RC_DIR},g' \
-e 's,%%RC_SUFX%%,${RC_SUFX},g'