aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap23-server/Makefile
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-11-30 22:27:00 +0800
committereik <eik@FreeBSD.org>2004-11-30 22:27:00 +0800
commit321ad1057e28cb47ddb89426eb94813c719b0280 (patch)
tree8716c3281676e0a9220584dc6296f7ad21862dfe /net/openldap23-server/Makefile
parentfdd100c10f16629696079db179f40c39e9689563 (diff)
downloadfreebsd-ports-gnome-321ad1057e28cb47ddb89426eb94813c719b0280.tar.gz
freebsd-ports-gnome-321ad1057e28cb47ddb89426eb94813c719b0280.tar.zst
freebsd-ports-gnome-321ad1057e28cb47ddb89426eb94813c719b0280.zip
update to OpenLDAP 2.2.19:
- Fixed back-bdb cache bugs (OpenLDAP ITS#3356, #3358), ctxcsn memory leak - Added support for BDB 4.3 (depends on PR 73790) NOTE: Don't use BDB 4.3 in production environments yet: <http://www.openldap.org/lists/openldap-software/200411/msg00700.html> For a complete change log see: /usr/local/share/doc/openldap/CHANGES
Diffstat (limited to 'net/openldap23-server/Makefile')
-rw-r--r--net/openldap23-server/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 838466d53554..7c96b9236559 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.18
+PORTVERSION= 2.2.19
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -188,7 +188,13 @@ PLIST_SUB+= BACK_BDB="@comment " \
WITH_BDB_VER?= 42
-.if ${WITH_BDB_VER} == 42
+.if ${WITH_BDB_VER} == 43
+CONFIGURE_ARGS+= --enable-bdb=${BACKEND_ENABLE} \
+ --enable-hdb=${BACKEND_ENABLE}
+PLIST_SUB+= BACK_BDB=${BACKEND_PLIST} \
+ BACK_HDB=${BACKEND_PLIST}
+BDBLIB= db-4.3.0
+.elif ${WITH_BDB_VER} == 42
CONFIGURE_ARGS+= --enable-bdb=${BACKEND_ENABLE} \
--enable-hdb=${BACKEND_ENABLE}
PLIST_SUB+= BACK_BDB=${BACKEND_PLIST} \