aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap23-server/Makefile
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-03-25 09:46:54 +0800
committereik <eik@FreeBSD.org>2004-03-25 09:46:54 +0800
commite3e9b999837bd6c16866224f1d4000d9d64a9e35 (patch)
treee06a050ff7812c795121d4b71bf9ab3275d5335b /net/openldap23-server/Makefile
parent025aef844a5665442d9376e586c3e115d48af710 (diff)
downloadfreebsd-ports-gnome-e3e9b999837bd6c16866224f1d4000d9d64a9e35.tar.gz
freebsd-ports-gnome-e3e9b999837bd6c16866224f1d4000d9d64a9e35.tar.zst
freebsd-ports-gnome-e3e9b999837bd6c16866224f1d4000d9d64a9e35.zip
use included libtool
Diffstat (limited to 'net/openldap23-server/Makefile')
-rw-r--r--net/openldap23-server/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 963298af4634..3739c5834177 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -62,7 +62,7 @@ CONFLICTS+= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[013-9].*
USE_OPENSSL= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
@@ -121,14 +121,14 @@ CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
--enable-null \
--enable-monitor
-WITH_BDB_VER?= 42
-
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --with-ldbm-api=bcompat \
--disable-bdb
.else
CONFIGURE_ARGS+= --with-ldbm-api=berkeley
+WITH_BDB_VER?= 42
+
.if ${WITH_BDB_VER} == 42
LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
CONFIGURE_ARGS+= --enable-bdb
@@ -182,7 +182,8 @@ CONFIGURE_ARGS+= --enable-sql
.if defined(WITH_SLAPI)
LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl
-CONFIGURE_ARGS+= --enable-slapi
+CONFIGURE_ARGS+= --enable-slapi \
+ --enable-modules
PLIST_SUB+= SLAPI=""
INSTALLS_SHLIB= yes
.else
@@ -261,8 +262,6 @@ pre-configure:
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
- ${WRKSRC}/configure
post-build:
.for script in slapd slurpd