aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap23-server/Makefile
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-10-12 07:22:33 +0800
committereik <eik@FreeBSD.org>2004-10-12 07:22:33 +0800
commitfb8a8c363d2cfdd5989c623adc35865ad92af140 (patch)
treeddc8e5ac68bddf22a89ab99e3b439369a435842e /net/openldap23-server/Makefile
parentcb673a8ccc0c7570d613c1e94d3ba6a5fda00b8a (diff)
downloadfreebsd-ports-gnome-fb8a8c363d2cfdd5989c623adc35865ad92af140.tar.gz
freebsd-ports-gnome-fb8a8c363d2cfdd5989c623adc35865ad92af140.tar.zst
freebsd-ports-gnome-fb8a8c363d2cfdd5989c623adc35865ad92af140.zip
- update to version 2.2.17
+ http://www.openldap.org/lists/openldap-announce/200409/msg00001.html + Fixed slapd syncrepl memory leak bugs - change default ldapi:// socket - use IGNORE instead of .error
Diffstat (limited to 'net/openldap23-server/Makefile')
-rw-r--r--net/openldap23-server/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index d9b277e0a54e..893827852a1e 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.2.15
+PORTVERSION= 2.2.17
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -62,7 +62,7 @@ PORTDOCS= CHANGES drafts rfc
.endif
.if defined(USE_OPENLDAP)
-.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
+IGNORE= : You have \`USE_OPENLDAP' defined either in your environment or in make(1) arguments
.endif
.else
OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
@@ -213,7 +213,7 @@ PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB="@comment "
BDBLIB= db3.3
.else
-.error WITH_BDB_VER must be 3, 4, 41 or 42
+IGNORE= : WITH_BDB_VER must be 3, 4, 41 or 42
.endif
LIB_DEPENDS+= ${BDBLIB}:${PORTSDIR}/databases/db${WITH_BDB_VER}
@@ -252,7 +252,7 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.elif ${WITH_ODBC_TYPE:L} == unixodbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.else
-.error WITH_ODBC_TYPE must be iODBC or unixODBC
+IGNORE= : WITH_ODBC_TYPE must be iODBC or unixODBC
.endif
.else
PLIST_SUB+= BACK_SQL="@comment "
@@ -266,6 +266,10 @@ INSTALLS_SHLIB= yes
PLIST_SUB+= SLAPI="@comment "
.endif
+.if defined(WITH_CLDAP)
+CPPFLAGS+= -DLDAP_CONNECTIONLESS
+.endif
+
# Include tcp-wrapper support
.if !defined(WITHOUT_TCP_WRAPPERS) && exists(/usr/include/tcpd.h)
CONFIGURE_ARGS+= --enable-wrappers