aboutsummaryrefslogtreecommitdiffstats
path: root/net/openmcu
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2003-08-28 15:32:44 +0800
committerroger <roger@FreeBSD.org>2003-08-28 15:32:44 +0800
commitd24f05d394a5b5d7808a9cedc8ae3f7ba937751d (patch)
tree0768984c89f1aa9ceaafa49796e5d1fb4d67a23d /net/openmcu
parentf7ccec86068f7acaec0236f6da49faea6c432ad3 (diff)
downloadfreebsd-ports-gnome-d24f05d394a5b5d7808a9cedc8ae3f7ba937751d.tar.gz
freebsd-ports-gnome-d24f05d394a5b5d7808a9cedc8ae3f7ba937751d.tar.zst
freebsd-ports-gnome-d24f05d394a5b5d7808a9cedc8ae3f7ba937751d.zip
Upgrade to 1.1.7
Diffstat (limited to 'net/openmcu')
-rw-r--r--net/openmcu/Makefile6
-rw-r--r--net/openmcu/distinfo2
-rw-r--r--net/openmcu/files/patch-main19
3 files changed, 23 insertions, 4 deletions
diff --git a/net/openmcu/Makefile b/net/openmcu/Makefile
index 9efb66ab7256..5c46f7757c43 100644
--- a/net/openmcu/Makefile
+++ b/net/openmcu/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= openmcu
-PORTVERSION= 1.1.5
+PORTVERSION= 1.1.7
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
http://www.ru.openh323.org/bin/
-DISTNAME= openmcu_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= roger@FreeBSD.org
COMMENT= OpenMCU hosts a conference call for H323 Video Conferencing users
@@ -25,7 +25,7 @@ NOCLEANDEPENDS= yes
USE_BISON= yes
USE_GMAKE= yes
ALL_TARGET= optnoshared
-MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
diff --git a/net/openmcu/distinfo b/net/openmcu/distinfo
index 0e0f55df8519..7a61a9a6dcee 100644
--- a/net/openmcu/distinfo
+++ b/net/openmcu/distinfo
@@ -1 +1 @@
-MD5 (openmcu_1.1.5.tar.gz) = 174018e8a07adda3631b23e5bc59d0ea
+MD5 (openmcu_1.1.7.tar.gz) = 041c468256f426e9e5a8cec0cdc769f6
diff --git a/net/openmcu/files/patch-main b/net/openmcu/files/patch-main
new file mode 100644
index 000000000000..d5edeaf0f5f7
--- /dev/null
+++ b/net/openmcu/files/patch-main
@@ -0,0 +1,19 @@
+*** main.cxx.orig Thu Aug 28 08:27:00 2003
+--- main.cxx Thu Aug 28 08:27:11 2003
+***************
+*** 261,267 ****
+ #include "speexcodec.h"
+ #ifndef NO_VIDEO
+ #include "h261codec.h"
+! #include "videoio.h"
+ #endif
+ #include "main.h"
+
+--- 261,267 ----
+ #include "speexcodec.h"
+ #ifndef NO_VIDEO
+ #include "h261codec.h"
+! //#include "videoio.h"
+ #endif
+ #include "main.h"
+