aboutsummaryrefslogtreecommitdiffstats
path: root/net/openmpi
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-08-17 22:20:40 +0800
committermat <mat@FreeBSD.org>2015-08-17 22:20:40 +0800
commit92a3a7b1bca5423036bca4932e5384d3e51591bd (patch)
tree16be3a9188cf2781563095e15839c170074dd7a7 /net/openmpi
parented2992b93f898f5612b3952782ac7d9206ed029a (diff)
downloadfreebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.tar.gz
freebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.tar.zst
freebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.zip
Remove UNIQUENAME and LATEST_LINK.
UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now, we won't have conflicts there. Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel has the correct PKGNAME anyway. Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called OPTIONS_FILE now.) Reviewed by: antoine, bapt Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3336
Diffstat (limited to 'net/openmpi')
-rw-r--r--net/openmpi/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index ed32d0ed0bb0..8caf697e1582 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -24,7 +24,7 @@ USES= fortran gmake libtool:keepla perl5 pkgconfig tar:bzip2
USE_PERL5= build
MPIBASE?= mpi
-MPIDIR?= ${MPIBASE}/${UNIQUENAME}
+MPIDIR?= ${MPIBASE}/${PKGBASE}
PLIST_SUB+= MPIBASE=${MPIBASE}
PLIST_SUB+= MPIDIR=${MPIDIR}