aboutsummaryrefslogtreecommitdiffstats
path: root/net/openpgm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-31 18:18:45 +0800
committerbapt <bapt@FreeBSD.org>2014-10-31 18:18:45 +0800
commit3402784a2fb4a996e0ab00688a243e5ebdd10684 (patch)
treeca100e92726c27ed2964b4385e6ccfdd6fa67b7c /net/openpgm
parent684a9b9268805e17a18625c98297738f0c2ff47d (diff)
downloadfreebsd-ports-gnome-3402784a2fb4a996e0ab00688a243e5ebdd10684.tar.gz
freebsd-ports-gnome-3402784a2fb4a996e0ab00688a243e5ebdd10684.tar.zst
freebsd-ports-gnome-3402784a2fb4a996e0ab00688a243e5ebdd10684.zip
Strip binaries
Avoid useless include of bsd.port.options.mk by letting plist handle what to add in the package or not
Diffstat (limited to 'net/openpgm')
-rw-r--r--net/openpgm/Makefile14
-rw-r--r--net/openpgm/pkg-plist55
2 files changed, 26 insertions, 43 deletions
diff --git a/net/openpgm/Makefile b/net/openpgm/Makefile
index 53c0ecae3aa9..db98a7562944 100644
--- a/net/openpgm/Makefile
+++ b/net/openpgm/Makefile
@@ -17,29 +17,17 @@ GNU_CONFIGURE= yes
USES= pathfix perl5 tar:bzip2 libtool python
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/openpgm/pgm
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS EXAMPLES
DOCS_DESC= Install documetation
EXAMPLES_DESC= Install examples
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-PLIST_SUB+= EXAMPLES=""
-.else
-PLIST_SUB+= EXAMPLES="@comment "
-.endif
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/../doc/draft-ietf-rmt-bb-pgmcc-03.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/../doc/rfc3208.txt ${STAGEDIR}${DOCSDIR}
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} examples ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/net/openpgm/pkg-plist b/net/openpgm/pkg-plist
index 2ac42285e7b7..ba85c8b218e7 100644
--- a/net/openpgm/pkg-plist
+++ b/net/openpgm/pkg-plist
@@ -27,33 +27,28 @@ lib/libpgm.so
libdata/pkgconfig/openpgm-5.2.pc
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-rmt-bb-pgmcc-03.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc3208.txt
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/SConscript
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/SConscript89
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/async.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/async.h
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/blocksyncrecv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/daytime.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecvmsg.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecvmsgv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/getopt.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/getopt.h
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/heatmap.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/pgmdump.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/pgmping.cc
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/pgmrecv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/pgmsend.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/pgmtop.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/ping.proto
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/pnonblocksyncrecv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/purinrecv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/purinrecvcc.cc
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/purinsend.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/purinsendcc.cc
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/shortcakerecv.c
-%%EXAMPLES%%%%EXAMPLESDIR%%/examples/snonblocksyncrecv.c
-%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%/examples
-%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm include/pgm-5.2/pgm
-@dirrm include/pgm-5.2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/SConscript
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/SConscript89
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/async.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/async.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/blocksyncrecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/daytime.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecvmsg.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecvmsgv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/getopt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/getopt.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/heatmap.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmdump.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmping.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmrecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmsend.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmtop.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/ping.proto
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pnonblocksyncrecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinrecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinrecvcc.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinsend.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinsendcc.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/shortcakerecv.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/snonblocksyncrecv.c