aboutsummaryrefslogtreecommitdiffstats
path: root/net/openser
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-04 14:34:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-04 14:34:05 +0800
commit35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f (patch)
tree99001edb2fb6eba2392e4ff305e6b1a997e7561c /net/openser
parent049c77b508e5f4c67680f1de0bfc84a2e4f86db8 (diff)
downloadfreebsd-ports-gnome-35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f.tar.gz
freebsd-ports-gnome-35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f.tar.zst
freebsd-ports-gnome-35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f.zip
Convert to new options framework
While here trim parts related to unsupported FreeBSD versions
Diffstat (limited to 'net/openser')
-rw-r--r--net/openser/Makefile36
1 files changed, 15 insertions, 21 deletions
diff --git a/net/openser/Makefile b/net/openser/Makefile
index e9b5d05bc150..bdaf8503dd33 100644
--- a/net/openser/Makefile
+++ b/net/openser/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openser
-# Date created: 20 October 2005
-# Whom: jesusr
-#
+# Created by: jesusr
# $FreeBSD$
-#
PORTNAME= openser
PORTVERSION= 1.2.3
@@ -59,16 +55,14 @@ PORTDOCS= *
SUB_FILES= pkg-install pkg-deinstall
SUB_LIST= RC_DIRS="${RC_DIRS}" RC_FILES="${RC_FILES}"
-OPTIONS= MYSQL "MySQL support" on \
- POSTGRESQL "PostgreSQL support" off \
- UNIXODBC "UnixODBC support" off \
- TLS "TLS support" off \
- SNMPSTATS "SNMPStats support" off \
- AUTHRADIUS "auth_radius module" off
+OPTIONS_DEFINE= MYSQL PGSQL UNIXODBC TLS SNMPSTATS AUTHRADIUS
+OPTIONS_DEFAULT= MYSQL
+SNMPSTATS_DESC= SNMPStats support
+AUTHRADIUS_DESC= auth_radius module
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
MODULES+= mysql
PLIST_FILES+= lib/openser/openserctl/openserctl.mysql sbin/openser_mysql.sh
@@ -76,22 +70,22 @@ PLIST_FILES+= lib/openser/openserctl/openserctl.mysql sbin/openser_mysql.sh
MAKE_ENV+= MYSQL=mysql
.endif
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
MODULES+= postgres
PLIST_FILES+= lib/openser/openserctl/openserctl.pgsql sbin/openser_postgresql.sh
.else
-MAKE_ENV+= POSTGRESQL=postgres
+MAKE_ENV+= PGSQL=postgres
.endif
-.if defined(WITH_UNIXODBC)
+.if ${PORT_OPTIONS:MUNIXODBC}
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
MODULES+= unixodbc
.else
MAKE_ENV+= UNIXODBC=unixodbc
.endif
-.if defined(WITH_TLS)
+.if ${PORT_OPTIONS:MTLS}
MODULES+= tlsops
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
TLS_RC_FILES= tls/rootCA/cacert.pem \
@@ -119,14 +113,14 @@ MAKE_ENV+= TLSOPS=tlsops
MAKE_ARGS+= TLS=""
.endif
-.if defined(WITH_SNMPSTATS)
+.if ${PORT_OPTIONS:MSNMPSTATS}
RUN_DEPENDS+= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp
MODULES+= snmpstats
.else
MAKE_ENV+= SNMPSTATS=snmpstats
.endif
-.if defined(WITH_AUTHRADIUS)
+.if ${PORT_OPTIONS:MAUTHRADIUS}
MODULES+= auth_radius
PLIST_FILES+= lib/openser/modules/auth_radius.so
.else
@@ -137,7 +131,7 @@ PLIST_FILES+= ${MODULES:S|^|lib/openser/modules/|:S|$|.so|} \
${RC_FILES:S|^|etc/openser/|:S|$|.default|}
post-patch:
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's|install-doc install-man|install-man|' \
${WRKSRC}/Makefile
.endif
@@ -176,4 +170,4 @@ post-install:
.endfor
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>