aboutsummaryrefslogtreecommitdiffstats
path: root/net/openslp
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-04 14:34:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-04 14:34:05 +0800
commit35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f (patch)
tree99001edb2fb6eba2392e4ff305e6b1a997e7561c /net/openslp
parent049c77b508e5f4c67680f1de0bfc84a2e4f86db8 (diff)
downloadfreebsd-ports-gnome-35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f.tar.gz
freebsd-ports-gnome-35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f.tar.zst
freebsd-ports-gnome-35c2a8a4cbddf9eb3458e4e18699b1e0e96cc84f.zip
Convert to new options framework
While here trim parts related to unsupported FreeBSD versions
Diffstat (limited to 'net/openslp')
-rw-r--r--net/openslp/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/net/openslp/Makefile b/net/openslp/Makefile
index 908f7c61235f..3da2a49d3f14 100644
--- a/net/openslp/Makefile
+++ b/net/openslp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OpenSLP 1.0
-# Date created: 15 Sep 2001
-# Whom: Joe Clarke
-#
+# Created by: Joe Clarke
# $FreeBSD$
-#
PORTNAME= openslp
PORTVERSION= 1.2.1
@@ -23,16 +19,17 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/openslp \
USE_RC_SUBR= slpd
-OPTIONS= SLP_SECURITY "Turn on SLPv2 security support" off \
- ASYNC_API "Enable asynchronous communication API" off
+OPTIONS_DEFINE= SLP_SECURITY ASYNC_API DOCS
+SLP_SECURITY_DESC= Turn on SLPv2 security support
+ASYNC_API_DESC= Enable asynchronous communication API
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SLP_SECURITY)
+.if ${PORT_OPTIONS:MSLP_SECURITY}
CONFIGURE_ARGS+= --enable-slpv2-security
.endif
-.if defined(WITH_ASYNC_API)
+.if ${PORT_OPTIONS:MASYNC_API}
CONFIGURE_ARGS+= --enable-async-api
.endif
@@ -45,11 +42,11 @@ post-install:
.for FILE in slp.conf slp.reg slp.spi
${INSTALL_DATA} ${WRKSRC}/etc/${FILE} ${PREFIX}/etc/openslp/${FILE}.default
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
(cd ${INSTALL_WRKSRC}/doc; \
${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/\{} \; ;\
${FIND} . -type f -exec ${INSTALL_DATA} \{} ${DOCSDIR}/\{} \;)
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>