aboutsummaryrefslogtreecommitdiffstats
path: root/net/openvswitch
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-27 19:57:18 +0800
committermarino <marino@FreeBSD.org>2014-07-27 19:57:18 +0800
commit9f206e3f9a2685127e956845f865439941893c3d (patch)
treea87fa6fc821fd74ea4d661a08b12d0bec07313bf /net/openvswitch
parente6925319fa4f6036f7fa65fec035b4080e3cbc2e (diff)
downloadfreebsd-ports-gnome-9f206e3f9a2685127e956845f865439941893c3d.tar.gz
freebsd-ports-gnome-9f206e3f9a2685127e956845f865439941893c3d.tar.zst
freebsd-ports-gnome-9f206e3f9a2685127e956845f865439941893c3d.zip
Stage net/openvswitch then pet portlint
PR: 192103 Submitted by: Ed Maste
Diffstat (limited to 'net/openvswitch')
-rw-r--r--net/openvswitch/Makefile13
-rw-r--r--net/openvswitch/pkg-descr2
-rw-r--r--net/openvswitch/pkg-plist26
3 files changed, 30 insertions, 11 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 19b6f1615252..a4a544342ee3 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -12,23 +12,16 @@ COMMENT= Production quality, multilayer virtual switch
LICENSE= APACHE20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= SSL_LIBS=-lssl SSL_CFLAGS=-I/usr/include/openssl
+CONFIGURE_ARGS= PERL=${PREFIX}/bin/perl
+CONFIGURE_ARGS+=SSL_LIBS=-lssl SSL_CFLAGS=-I/usr/include/openssl
USE_AUTOTOOLS= autoconf automake
USES= gmake pkgconfig
USE_PYTHON= yes
USE_RC_SUBR= ovs-vswitchd ovsdb-server
-MAN1= ovs-benchmark.1 ovs-pcap.1 ovs-tcpundump.1 ovsdb-client.1 \
- ovsdb-server.1 ovsdb-tool.1
-MAN5= ovs-vswitchd.conf.db.5
-MAN8= ovs-appctl.8 ovs-brcompatd.8 ovs-bugtool.8 ovs-controller.8 \
- ovs-ctl.8 ovs-dpctl.8 ovs-ofctl.8 ovs-parse-leaks.8 ovs-pki.8 \
- ovs-test.8 ovs-vsctl.8 ovs-vswitchd.8 \
- ovs-vlan-bug-workaround.8 ovs-vlan-test.8
OPTIONS_DEFINE= THREADED
THREADED_DESC= Experimental high-performance threading patch
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MTHREADED}
@@ -48,7 +41,7 @@ post-patch:
.endif
post-install:
- ${INSTALL_DATA} ${WRKSRC}/vswitchd/vswitch.ovsschema ${PREFIX}/share/openvswitch/
+ ${INSTALL_DATA} ${WRKSRC}/vswitchd/vswitch.ovsschema ${STAGEDIR}${PREFIX}/share/openvswitch/
#regression-test: build
# @cd ${WRKSRC} && ${MAKE_CMD} check
diff --git a/net/openvswitch/pkg-descr b/net/openvswitch/pkg-descr
index 2b1fdd4ee369..773574425073 100644
--- a/net/openvswitch/pkg-descr
+++ b/net/openvswitch/pkg-descr
@@ -6,4 +6,4 @@ ERSPAN, CLI, LACP, 802.1ag). In addition, it is designed to support
distribution across multiple physical servers similar to VMware's vNetwork
distributed vswitch or Cisco's Nexus 1000V.
-WWW: http://openvswitch.org/
+WWW: http://openvswitch.org/
diff --git a/net/openvswitch/pkg-plist b/net/openvswitch/pkg-plist
index 8ba06eedffd3..211b6a42f687 100644
--- a/net/openvswitch/pkg-plist
+++ b/net/openvswitch/pkg-plist
@@ -12,6 +12,27 @@ bin/ovs-pcap
bin/ovs-tcpundump
bin/ovs-test
bin/ovs-vlan-test
+man/man1/ovs-benchmark.1.gz
+man/man1/ovs-pcap.1.gz
+man/man1/ovs-tcpundump.1.gz
+man/man1/ovsdb-client.1.gz
+man/man1/ovsdb-server.1.gz
+man/man1/ovsdb-tool.1.gz
+man/man5/ovs-vswitchd.conf.db.5.gz
+man/man8/ovs-appctl.8.gz
+man/man8/ovs-brcompatd.8.gz
+man/man8/ovs-bugtool.8.gz
+man/man8/ovs-controller.8.gz
+man/man8/ovs-ctl.8.gz
+man/man8/ovs-dpctl.8.gz
+man/man8/ovs-ofctl.8.gz
+man/man8/ovs-parse-leaks.8.gz
+man/man8/ovs-pki.8.gz
+man/man8/ovs-test.8.gz
+man/man8/ovs-vlan-bug-workaround.8.gz
+man/man8/ovs-vlan-test.8.gz
+man/man8/ovs-vsctl.8.gz
+man/man8/ovs-vswitchd.8.gz
sbin/ovs-vswitchd
sbin/ovsdb-server
sbin/ovs-bugtool
@@ -65,8 +86,13 @@ share/openvswitch/scripts/ovs-bugtool-vsctl-show
share/openvswitch/scripts/ovs-bugtool-daemons-ver
share/openvswitch/scripts/ovs-bugtool-bond-show
@dirrmtry var/log/openvswitch
+@dirrmtry var/log
@dirrmtry var/lib/openvswitch/pki
@dirrmtry var/lib/openvswitch
+@dirrmtry var/lib
+@dirrmtry var/run/openvswitch
+@dirrmtry var/run
+@dirrmtry var
@dirrmtry share/openvswitch/scripts
@dirrmtry share/openvswitch/python/ovstest
@dirrmtry share/openvswitch/python/ovs/db